Announcement

Collapse
No announcement yet.

Attached to new email error 00000002

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attached to new email error 00000002

    The machine is a Windows 10 Pro 64 with (licensed) PhantomPDF 8.0.1.1013 and MS Office Pro 2016; so I am using MS Outlook locally as email client.

    With a PDF open and using PhantomPDF share toolbar or the email icon on the quick access toolbar; if I choose to attach the current file to a new email message a failure error is displayed; error 00000002. If I right click on a PDF, for example on my desktop, and choose to send-to and email attachment no error is displayed and nothing happens at all.

    These failures may be related and I am trying to find out what I need to do to get it working properly.

    Here are some things I've tinkered with.
    With a new Outlook message started I can drag-and-drop a PDF and send; works as expected.
    I right-clicked on a small txt file on my desktop and choose send-to email recipient and the outlook new message is displayed with attachment as expected.
    Next I right-clicked on a PDF and choose send-to email recipient and nothing happened; or so it appears.
    I right-clicked on a JPG or PNG and choose send-to and the resize before sending box was displayed as expected.

    One other thing I tried with 8.0.1 was to execute the check-for-update on the help toolbar. With Phantom off, well it was still running as a background process so I had to kill the FoxitPhantomPDF.exe process before the update would continue. It failed anyways. So I restarted PhantomPDF, triggered the update window and killed the process before executing the update and it again failed so running the update feature didn't help.

    I have another machine with version 7.3.9.816 on it and it works, always has; It's a Windows 10 Pro 64 and Outlook 2010. So I tried this version on the machine with the error.

    I Uninstalled version 8.0.1 and installed version 7.3.9 in its place. In doing this I first switched the default PDF reader to Adobe X. After running the uninstall I booted. With version 7.3.9 installed the same error was produced using the software the same way as before. I have version 7.3.9 installed now. I'm sure the uninstall process didn't clean up some files somewhere that maybe I need to do myself but I thought I would go ahead and post this and see what response I get.

    Print, edit, organize, convert, open, close, combine and other features of PhantomPDF work as expected. It's the email piece that produces the error. I've got a snag between Phantom and Outlook.

    My local machine Outlook is my default email program, PhantomPDF is my default reader.

    Any suggestion please.

    ddollar

  • #2
    Please open a .doc file and go to "File > Share > Email as Attachment" in Office Word, and check if you can email successfully from Word program.
    If you get the same issue in Office Word, it means that there is something wrong with MS Outlook, please open Control Panel, Add-Remove programs, locate Microsoft Office , Click on Change and initiate a repair of the installation to see if it helps.
    If the issue persists in Word program after repair, please contact Microsoft support to get help.

    If it just happens to Foxit, please download the file MAPITestWithUI.rar from the following message and unzip and run MAPITestWithUI.exe.
    Then you can find 5 buttons (Test 1,Test 2...Test5) in the program, every buttons have its own emailing operations, please click the buttons one by one and check that which button is working, it means you can get the emailing window.

    http://sync-us.foxitsoftware.com/iss/mantis62071/MAPITestWithUI.rar


    After test, please let me know which button is working and send us the file MAPITest.log.

    Comment


    • #3
      Okay I think I found what caused the error. The suggestion of using Word to share email as attachment failed and generated a MAPI unspecified error. While looking that up I came across the registry setting for MaximumAttachmentSize and on this machine it was set to 0. The idea was to prevent the machine from blocking large attachments. The default was something like 20M and 0 was to represent an unlimited size.

      I found something here on the MAPI unspecified error.
      https://social.msdn.microsoft.com/Fo...?forum=worddev

      I set the MaximumAttachmentSize to 50000 and without booting tested the send email from within PhantomPDF and Word send as attachment and both work properly.

      It's fixed now.

      Thank you Doris.

      Comment


      • #4
        ddollar


        Thank you for your sharing.

        Comment


        • #5
          [Edit: Don't know what helped but I updated Crystal Reports and re-boot the computer and now everything works. ]


          Hello!
          I am having quite the same problem now when I had to change my computer.
          Email error 0000002 is given BUT attaching Word -dokument works. Also attaching files to a new message at Outlook works fine.
          Only attaching from Foxit does not work. Any advice what to check..?
          Last edited by jjantti; 01-18-2017, 07:31 AM.

          Comment


          • #6
            jjantti

            Please help to provide us with the following info;
            1. Does it happen to any pdf files? If it is a specific file, please check the file size, if the file size exceeds 32M, you will get the error.
            2. Press "Window + r" input "regedit" press Enter, navigate to HKEY_CLASSES_USER -> Software -> Microsoft -> Office -> 15.0 -> Outlook -> Preferences -> Maximum Attachment Size, send us the value of "Maximum Attachment Size" .
            3. The version of Outlook you use.
            4. The version of Foxit PhantomPDF you use.
            5. In addition, please go to Control Panel\All Control Panel Items\Default Programs\Set Default Programs, set your email program as default programs again, then restart your computer, email from Foxit to see if it helps.


            Comment

            Working...
            X