Announcement

Collapse
No announcement yet.

PhantomPDF process loop and credientials prompt.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PhantomPDF process loop and credientials prompt.

    We have deployed PhantomPDF v9.3 via group policy along with a transform and XML file, also have startup scripts to set as default and register the product. When users have tried to use the application it will prompt with credentials and there are 3 cases that occur. (Also checking if it is the default application, sometimes is has all defaults, sometimes 5 out of 6, sometimes 2 out of 6)

    1. The user puts in their creds and the application gets stuck in a loop, opening multiple PhantomPDF processes and not allowing them to close the application or use any other application. The only way to get out of this is to Ctrl+Alt+Del and sign out.

    2. The user hits no and the document opens fine, but the next time they open a document it prompts for creds again.

    3. Administrative creds are inputted and the application either works fine and doesn't prompt again or it goes into the loop mentioned in #1.

    The PCs OS is 8.1

    Any help appreciated.

  • #2
    rjlasb18 ,I apologize for the inconvenience. To set Foxit PhantomPDF as your system's default PDF viewer without triggering the UAC message for windows 8 and greater via Group policy or XML editor,please make sure to just CHECK the option"System PDF Viewer" and NOT CHECK option"Web browser PDF viewer" in GPO template settings or XML editor tool.
    Please refer to attached screenshots:GPO.jpg and XML editor.jpg.
    Then,the UAC message would just pop up only the first time when a user open Foxit PhantomPDF,users could just click on "NO" option without inputting admin account and password to simply close the UAC message,then the UAC message won't appear again anymore.
    If you even won't to get UAC message at the first time when a user open Foxit PhantomPDF,you could consider to follow the instructions in the attached document"Using GPO to Set Default PDF Viewer under Win8.docx" to install Foxit as default.
    Attached Files

    Comment


    • #3
      Thank you, I will go ahead and try this via group policy.

      Is there any information on why PhantomPDF and also Foxit Reader tax the system when you put in credentials and can not be closed or the task ended. In task manager there are a large number of PhantomPDF processes and it uses the majority of the CPU. Any information would be great to configure the product differently or be able to get out of the application.

      Comment


      • #4
        rjlasb18 ,I am sorry that there is no other user who has reported such issue yet. For this situation,would you please help to use the LiceCap tool to generate an animated gif that shows how to reproduce the problem for our referencing.
        Here's the download link:
        http://sync-cn.foxitsoftware.com/iss/Tools/LICEcap.zip
        (Unzip it, then double-click on licecap file, you can then specify the recording area then hit "Record", it requires naming the file first then start recording.)
        When this issue happens,please open Task Manager, look into the Process tab,make sure CPU and GUI Objects visible on screen, and make a screen shots for us. If the GDI Objects wasn’t listed in the column, please go to View > Select Columns…, find the GDI Objects and check the check box to enable it.
        At the same time of above step, please go to Performance tab, make a screen shot of the screen for us.

        Comment

        Working...
        X