Announcement

Collapse
No announcement yet.

Bug: Night Mode prevents colored text

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug: Night Mode prevents colored text

    Hello,

    I have a .docx document that I created in Word. There's black text but also some red and green text. When I open the converted to .pdf document in Foxit, and read it in Night Mode, the colored text is shown as the black one (i.e. white on dark background). I don't think it's the intended behavior. It would be illogical.

    See attachment for better understanding if my English is not good enough: https://i.postimg.cc/ryBVJZFp/night-mode-bug.png


    Thanks for investing,

    creal.

  • #2
    creal Thanks for your feedback. May I know what's version of Foxit PDF Editor installed on your end? Can you please update Foxit to latest version 11.1 and try again? If issue persists, can you please send sample file to us for testing? thanks.
    Last edited by amanda_liang; 11-05-2021, 06:53 AM.

    Comment


    • #3
      Hello Amanda,

      I already run 11.1 version. Here is a sample I just made with Word: 3 lines, with one color each.

      Link: https://we.tl/t-k7aA5jaimW

      Cheers.

      PS: I can't attach files directly to a post because I have the following error: "You are not authorized to create or remove attachments"

      Comment


      • #4
        creal

        Thank you for your file. Do you just enable Night Mode by View>Night Mode? Would you please open Foxit, go to File>Preferences>Accessibility, check if you have enabled the option "Replace Document Color" now? Or set it previously but disabled now?
        Now we can reproduce the issue if we enabled "Replace Document Color" previously, and later we disabled, it will affect Night Mode. Case ID#QCPHANTOM-28727.
        If you have same case, please press "Window + r" input "regedit" press Enter, find folder "Foxit PDF Editor" under the directory "HKEY_CURRENT_USER\Software\Foxit Software\Foxit PDF Editor" and delete it. Please note, it will delete all your preferences and go back to factory settings.




        Attached Files

        Comment


        • #5
          Thanks for your message, Lyndi.

          You are right. The option "Replace document color" was previously checked for enabling an artificial dark mode. I am glad you found the root of the problem. Because I don't want to lose all my preferences, I prefer to wait for the next update. Or maybe is it possible to just delete a sub-key in the "Foxit PDF Editor" registry?

          EDIT: only removing "Accessibility" sub-key didn't fix the bug.
          Last edited by creal; 11-05-2021, 12:41 PM.

          Comment


          • #6
            creal ´╝îThanks for your response. Please remove the following sub-key in Foxit PDF Editor registry key for making the Foxit PDF Editor to still display colored text as color one under Night mode:
            HKEY_CURRENT_USER\SOFTWARE\Foxit Software\Foxit PDF Editor 11.0\Preferences\Documents
            Any further questions or concerns,please contact us again at any time.



            Comment

            Working...
            X