No announcement yet.

Foxit Reader on Linux, unable to fill forms

  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Foxit Reader on Linux, unable to fill forms

    I have installed Foxit Reader on a 64 bit Debian Linux (kernel 4.7.0-1-amd64) machine. It displays fillable PDFs fine, although I am unable to fill any text in form fields. I tried changing tool from carrot to Hand and back, nothing works. I initially thought it might be problem with the PDF, so I downloaded f1040 from IRS website that has interactive fields and I can't fill that form either using this application.

    Any help is appreciated.
    Last edited by foxitnoworky; 01-24-2017, 01:25 AM.

  • #2

    Would you please send us the pdf form in question for internal test?
    If it is inconvenient to upload here, you may email the PDF document to
    Thank you in advance.


    • #3
      I couldn't attach the PDF here because of size restriction, so sent an email. The PDF is available online here:


      • #4
        Dear foxitnoworky,

        I am sorry that currently our Foxit Reader for Linux still doesn't support to fill out form fields. This form filling request has already been submitted as a
        new feature to our internal feature system with suggestion ID#MACLNX-139,so that it may be considered in future versions.