Announcement

Collapse
No announcement yet.

Can't get online pdf files to open in reader rather than in browser

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get online pdf files to open in reader rather than in browser

    I am using Foxit Reader version 8.1.0.1013. Until very recently I could open up pdf files that I found online in Foxit Reader. For the last two days I can no longer do this - the pdf files open automatically in the browser - both IE 11 and Firefox 5.1.0. I have read this problem happening to others but the solutions given don't seem to work for me. Any idea how I can get online pdfs to open in the reader again?
    Foxit Reader is a lightweight, fast, and secure PDF Reader capable of high-volume processing. Download the best free PDF Reader today.
    Last edited by forums.adm; 04-26-2017, 07:53 AM. Reason: remove adviertisement

  • #2
    broski23

    Interesting post. I'm the reverse actually - firefox has withdrawn NPAPI plugin support, so reading PDFs in the browser (using foxit's in-browser plugin) no longer works. I'm stuck with them opening in the reader.

    FIREFOX
    Anyway, although this KB article is for phantom, the principle is exactly the same for foxit reader:

    https://help.foxitsoftware.com/kb/co...df-plug-in.php

    You want step 2, then pick "use foxit reader 8.1" (since you say your version is 8.1) in firefox.

    The alternative, if it works, is to follow my instructions below for IE, which should remove ability to view PDFs in a browser altogether. Assuming there's support in Chrome for foxit previewing, this of course will affect Chrome too.

    I've attached a screenshot of what mine looks like. Your dropdown menu should include option to view with foxit in the browser. Note "preview" is using firefox's native viewer (not the same thing as foxit's).

    Click image for larger version  Name:	firefox options for selecting PDF default behaviour.JPG Views:	1 Size:	87.0 KB ID:	163584




    INTERNET EXPLORER
    This was interesting. I thought there might be an add-on to disable in IE but there doesn't appear to be. IE 'calls' foxit and opens in-browser.

    I've not tested this (since I'm in the middle of writing this post) but if you want to stop this happening, maybe you need to disable foxit in a browser (see below).

    You can do this by:

    1) going into Foxit's "preferences" (under the "file" tab)
    2) looking for "file associations"
    3) then "advanced"
    4) try clearing/unchecking "include browser when setting default PDF viewer".
    5) Obviously click ok, etc, to close all dialogue boxes. Might be worth closing and reopening foxit too.

    NOTE: I'd close ALL browsers you have open BEFORE changing the foxit file associations.

    Click image for larger version

Name:	image_5072.jpg
Views:	1
Size:	321.3 KB
ID:	163585






    UPDATING FIREFOX AND FOXIT
    A final observation. You're a bit behind versions, both with firefox and foxit. This is why my first screenshot says foxit reader 8.3. Public releases are:

    firefox 53.0
    foxit: 8.3.0.14878

    Maybe this is out of choice. It's normally recommended to use latest versions, as they 'should' be most stable / have bug-fixes etc and possibly more functionality.

    WARNING: as per my initial comment, firefox has withdrawn support for NPAPI plugins (with firefox 52 onwards). Although you don't want to view PDFs in the browser, this removal of plugin support effects stuff like java, silverlight, etc. Flash is the only plugin which has been preserved. You will lose basically all your firefox plugins, if you update.

    One option could be to move to 52 ESR (extended support release), which gives extended support (i think for a year) to NPAPI plugins.

    The flipside is that IMHO keeping your browser up-to-date is important for safety and security, so I'd recommend you update, even if you update to v52 ESR.



    Hope all this helps you.



    Regards,

    Gary

    Comment


    • #3
      Dear Gary,

      Thanks for the detailed instructions.For the "INTERNET EXPLORER" part you mentioned,I would like to advise you to click on the option"Make default PDF viewer"button also in the preferences dialog box after you have unchecked the option"Include browser when setting default PDF viewer" to make the the settings that you have made in the "Advanced..."to take effect.

      And the NPAPI plugins are not longer allowed in Firefox and Google chrome now,so users are unable to open online PDF file with Foxit plugin within Google chrome and Firefox web browser.
      Anyway,we have submitted the suggestion"make the Foxit plugin using the modern, secure PPAPI/Pepper plugins or HTML5, which will be supported by Chrome and firefox"to our internal feature system system for our product marketing's further reference with suggestion ID#PHANTOM-3457.

      Comment

      Working...
      X