Announcement

Collapse
No announcement yet.

Disabled ConnectedPDF features ...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disabled ConnectedPDF features ...

    Hi!
    Everything worked fine till Foxit Reader 8.3. (Foxit installed using msi.) We had Foxit service disabled and also "Disabled ConnectedPDF features" in ProfStore.xml. After installing 8.3 few days ago users started during Foxit start get errors "Cannot find required component or the version is incorrect. Please reinstall this application to fix this issue.". I may swear I tested 8.3 on test device and didn't get this error (I always test before publishing), but ... now I get this error also on test device. Odd. Anyway, this warning/error seems to not interfere in any functionality, pdf's still opening etc. First I didn't know where to look on this error, then I removed xml, everything did work ok, except all stuff appear at starting etc. removing which is xml for! Then I started to click on xml options and finally found "Disabled ConnectedPDF features" which we had checked. As soon I unchecked this option (~ features enabled) during Foxit start appear UAC box. When I started also Foxit service ... everything went ok. As soon I disabled features (service running) ... also same error appear. But ... we don't want these features to be enabled! I remind ... everything worked before 8.3 – no UAC popups nor errors and "Disabled ConnectedPDF features".
    Any ideas?
    More thanks, Alar.

  • #2
    Dear FoxAlf,
    Concerning the erorr message you got,we are aware of this case,this issue would happen when users choose diasble connectedPDF feature via Foxit Customization tool or XML editor for V8.3 of Foxit Reader or Foxit PhantomPDF.
    It will fix it in next major release 9.0. Our developer has complied the new registry key for you to import so the issue will be fixed.
    Please try the following instructions:
    1. Exit running Foxit Reader/Foxit PhantomPDF.
    2. Download the registry key from http://sync-cn.foxitsoftware.com/iss...677/reader.zip (phantom: http://sync-cn.foxitsoftware.com/iss...77/phantom.zip) and extract it.
    3. Double click on the disableCPDF_Reader/PhantomPDF8.x.reg and import it.
    4. Launch Foxit Reader/PhantomPDF to see if it helps.

    Comment


    • #3
      Hi!
      As my post(s) reach this forum after days (unfortunately), I found intermediate solution (perhaps same meant to be downloaded above) – when user does disable cPDF features via Foxit GUI (this means in xml it shouldn't be disabled this option to appear for user) then afterwards to disable this via xml ... no error or whatsoever. This means that admin's can set registry key under hkcu and ... voila!
      Alar.
      Btw, links provided for download not correct.

      Comment


      • #4
        I meant (for Foxit) ...
        ---
        Windows Registry Editor Version 5.00

        [HKEY_CURRENT_USER\Software\Foxit Software\Foxit Reader 8.0\ConnectedPDF]
        "DisablecPDF"=dword:00000001
        ---
        Alar.

        Comment


        • #5
          Dear FoxAlf,

          Thanks for informing us the previous links are not correct. I have rectified those links already.
          And the registry key file that I sent above is also for you to set the following regitry key:
          Windows Registry Editor Version 5.00
          [HKEY_CURRENT_USER\Software\Foxit Software\Foxit Reader 8.0\ConnectedPDF]
          "DisablecPDF"=dword:00000001

          Comment


          • #6
            Dear FoxAlf,

            Foxit Reader 8.3.1 is available now. The reported issue "Got missing component error message after having made the CPDF feature disabled" should have been fixed.
            You may download it from the following link and give it a try at your convenience:
            http://cdn01.foxitsoftware.com/pub/f..._enu_Setup.msi

            Comment

            Working...
            X