Announcement

Collapse
No announcement yet.

How to just apply a signature in new v8, vs. 7?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to just apply a signature in new v8, vs. 7?

    I had to upgrade to the current version and can NOT find how to just insert my signature from a file. It was easy in 7, and I found PDF Sign, but when I click on the form I want to apply it to, it asks for all sorts of weird info that has no relevance. I suspect I don't want it "signed", but just want to insert a signature from a picture file but can't seem to find that.

    Detailed instructions would be helpful, as I dislike the ribbon interfaces and have lots of trouble finding things that were known and easy to use. I'm still on Word 2003, and held out for long time on old 7 which allowed switching back to standard menus...

    Thanks.
    Last edited by RichE; 09-23-2017, 04:47 PM. Reason: Solved!

  • #2
    Hi RichE,

    The procedure to apply a signature in v8 and v7 are very similar. Here are the steps.

    1. Choose Protect > Protect > PDF Sign. The PDF SIGN tab appears on the toolbar.
    2. Click + button in the signature palette and choose Import File
    3. Click the created signature and place in the file.
    4. Right click the signature and choose Apply.


    As you mentioned that 'it asks for all sorts of weird info', not sure what it is but I guess this is matter in this case. If possible, please send us a screenshot to show the weird info that it asks for and the file you would like to sign to support@foxitsoftware.com for better advise.


    Comment


    • #3
      Thanks, but I found how to do it. It's NOT under PDF Sign at all, that's for something else (which is confusing). What I used is now called "Image Annotation". NOT intuitive at all. Should be something like "Insert image", keyword image. Under early 7 version I was using, this was, I believe, under something similar. Can't remember/tell now as you apparently can't have both versions installed at the same time. Oh, version I was using, last to keep the standard menus, was v728.1124. I don't know what happened, but suddenly I could no longer enter text in text form fields in a PDF. Worked fine literally minutes before. Hmmm, should have tried reinstalling 7 again to see if it fixed it first. I'll uninstall 8 and try reinstalling 7 and see if it works again.

      Thanks for trying.

      Comment

      Working...
      X