Announcement

Collapse
No announcement yet.

Foxit Reader Version: 9.0.1.1049 - UAC Prompt

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Foxit Reader Version: 9.0.1.1049 - UAC Prompt

    Just installed Foxit Reader Version: 9.0.1.1049 on Server 2012 R2. We publish an EMR via Citrix from these servers. The PDF viewing appears to be ok but when my users try to generate a print preview, they get a User Account Control prompt. Our users are not local admins, nor is that an option. Is there any way around this?

    I have also received reports of logos pulled from network share are not displaying on printed PDF's. Related issue?

    By the way, during install, I unchecked the box for ConnectedPDF.

  • #2
    Tried going to Properties of FoxitReader.exe and Compatibility tab, Settings for all users, and checking Run as Admin. But that produces even worse results by throwing a Release of Information error stating there was an error launching the preview file, which I suspect came from our EMR system.

    On a side note, once a user gets the UAC prompt and cancels out of it, then can immediately try the same action, and it works without prompting.

    Comment


    • #3
      So I managed to get a screenshot of the UAC details when this happens, see screenshot if it attaches correctly. In the Program Location path, it has this: "C:\Program Files (x86)\Foxit Software\Foxit Reader\FoxitReader.exe" -register

      Why is there a "register" switch??? I set the Remove 'Registration' option in Local Group Policy to Enabled.

      Click image for larger version

Name:	foxit uac.png
Views:	1
Size:	120.6 KB
ID:	166438

      Comment


      • #4
        So I went ahead and did the Registration through Foxit Reader and it said Thank You for Registering. Will I get a key of some sort emailed to me or something? If I click on the Registration Plugin again, it takes me back to same Registration web page as though I have never been there before.

        Comment


        • #5
          1. If I use Foxit GPO templates and Enable the Do not prompt for Registration, I get UAC prompt.
          2. If I use same GPO and choose Not Configured or Disable, I get prompted to Register, if I choose Later, I get UAC prompt.

          I haven’t found a way around it yet but basically I need to either Register Foxit, which I went through the process but have not received a Key yet, or find a way to suppress the entire Registration process.

          Any help would be greatly appreciated as this is a very time sensitive issue for me.

          Comment


          • #6
            Dear Jodale1972,

            I apologize for the inconvenience. Please install our .msi package of Foxit Reader which won't ask user to register it.
            Following is link for downloading .msi installer of Foxit Reader 9.0.1:
            http://cdn09.foxitsoftware.com/produ..._enu_Setup.msi
            And then please follow the instructions in the attached document"GPO_deployment_set default on Win8 machines.docx" to set Foxit as system default application without triggering the UAC message.

            Attached Files

            Comment


            • #7
              This was what I ended up doing. The first links I received from Support were the public versions and not Enterprise. The second time I called I got the correct MSI.

              Comment


              • #8
                Originally posted by Lisa_lee View Post
                Dear Jodale1972,

                I apologize for the inconvenience. Please install our .msi package of Foxit Reader which won't ask user to register it.
                Following is link for downloading .msi installer of Foxit Reader 9.0.1:
                http://cdn09.foxitsoftware.com/produ..._enu_Setup.msi
                And then please follow the instructions in the attached document"GPO_deployment_set default on Win8 machines.docx" to set Foxit as system default application without triggering the UAC message.
                So, I'm running the foxit reader msi which you says should not ask to register it when the user launches (UAC), but it still does. I'm needing a solution to this problem or I'm going to have to abandon foxit reader as a solution.

                Comment


                • #9
                  kevdog1971 ,

                  Sorry for any trouble that our product may have caused you.Would you please help to give us your OS information(eg:mine is windows 10x64bit) since we have to suppress the UAC message with different methods in different operating system?And please also help to take a screenshot of the UAC message that you mentioned so that we will take a closer look at first to know which component/feature in Foxit Reader triggers the message.
                  To make a screenshot, please press 'PrScrn SysrRq' on the keyboard, then go to 'Start'->'All Programs'->'Accessories'->'Paint'->press Ctrl V to paste and save.

                  Comment


                  • #10
                    Dear Foxit Support team,


                    Please note that we are encountering a UAC prompt issue for mostly all our users when opening PDF documents on Foxit Reader (Our default PDF application).

                    Foxit Reader installed is v9.1.0.5096

                    Please note that users are connected onto Windows Server 2016 Standard RDS session servers (64-bit OS).

                    We have followed the FoxitReaderDeploymentAndConfiguration9.1_Manual.pd f guide for the setup on our 2016 RDS servers.

                    I have also attached the Foxit Reader MSI details that was used for deployment across the RDS servers, please confirm if compatible with Windows Server 2016 STD.

                    The setup was customized using the Foxit Customisation tool to disable automatic updates.

                    File association has been set on via GPO using an XML file to default to Foxit Reader.

                    We have also suppressed the ConnectedPDF registry key on all our RDS servers with the below registry entry change.

                    HKCU\Software\Foxit Software\Foxit Reader 9.0\ConnectedPDF
                    CanShowConnectedPDFAboutDialog REG_Dword 0

                    Grateful if you could please advise urgently on the matter as this is hindering our users daily work.

                    Many thanks.

                    Regards,
                    Laurent

                    Comment


                    • #11
                      @AccuroIT

                      Please check if “Web Browser Viewer” is checked in GPO template and "Show PDF files in browsers" been checked. If yes, please uncheck the mentioned options as the checking of the mentioned settings will be written into the system registry's root directory, it would cause the UAC with tag -displayinbrowser.

                      If the UAC is with tag -register, please refer to the following:
                      To disable the UAC with tag –register, the end users can close the UAC prompt directly without entering admin account and password, this should be able to set Foxit Reader as default without problem. We've also submitted the suggestion about this UAC prompt so it would not pop up after we set Foxit Reader as default via Command line installation or GPO in the future. Suggestion ID#: QCPHANTOM-9281.
                      If IT doesn't want the users to see this prompt, IT will need to follow the steps in uploaded guide GPO_deployment on windows 8 and windows 10.docx to set Foxit Reader as default as workaround.
                      Attached Files

                      Comment


                      • #12
                        Originally posted by Jodale1972 View Post
                        Tried going to Properties of FoxitReader.exe and Compatibility tab, Settings for all users, and checking Run as Admin. But that produces even worse results by throwing a Release of Information error stating there was an error launching the preview file, which I suspect came from our EMR system.
                        Latest jobs in Sharjah

                        On a side note, once a user gets the UAC prompt and cancels out of it, then can immediately try the same action, and it works without prompting.
                        will it work with browsers?

                        Comment


                        • #13
                          vac2018

                          Checking "Show PDF files in browsers" will be written into the system registry's root directory, it would cause the UAC with tag -displayinbrowser. We need to uncheck this option when deploying the software.
                          BTW, Firefox, Google Chrome and Opera don't support the NPAPI style plugins, so Foxit PDF plug-in of version 9.2.0 or previous versions will not work in Firefox (version 52 and above), Google Chrome(version 45 and above) or Opera(version 12.17 and above) anymore. We've added this to the to-do list. Thank you.

                          Comment

                          Working...
                          X