Announcement

Collapse
No announcement yet.

Foxit Reader on 2012R2 RDS Server Prompting User for Admin Creds for First Time User

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Foxit Reader on 2012R2 RDS Server Prompting User for Admin Creds for First Time User

    Hi All,
    I have recently installed Foxit 9.1 onto an 2012R2 RDS server. I have deployed the GPOs for Foxit and disabled a few features such as the Advertisements and Automatic Update as well as the "Remove Registration" option. The first time a user opens Foxit they are prompted for admin creds. I'm unsure why this occurs but have noticed the "-register" switch added to the end of the command as per the attached.

    If you ignore this and close the UAC prompt Foxit opens fine and never appears again unless you reset the users profile. Any idea why this is happening and how to disable it?

    ​​​​​​​

    Click image for larger version

Name:	2018-06-26 15_53_09-ecords01.root.ecocentral__Shared.png
Views:	1
Size:	190.2 KB
ID:	167733

  • #2
    Dylan VS

    Sorry for the trouble. May I suggest you to redeploy Foxit Reader via GPO as the attached guidance to fix the issue?

    Attached Files

    Comment


    • #3
      I'm having the same issue in launching Foxit Reader on terminal servers (where users off course don't have admin rights). When launching, uac pops up, same as in screenshot above. CPDF is not active. Also it seems to be the "-register" option that invokes this.
      Above document is for setting Foxit as default pdf reader which is not what I want atm.
      GPO's are being applied but don't seem to have any influence on the issue. Is there a way to disable this startup with the register option?

      Comment


      • #4
        Nico

        To disable the UAC with tag –register, the end users can close the UAC prompt directly without entering admin account and password, this should be able to set Foxit Reader as default without problem. We've also submitted the suggestion about this UAC prompt so it would not pop up after we set Foxit Reader as default via Command line installation or GPO in the future. Suggestion ID#: QCPHANTOM-9281.
        If IT doesn't want the users to see this prompt, IT will need to follow the steps in uploaded guide GPO_deployment on windows 8 and windows 10.docx to set Foxit Reader as default as workaround. Thank you.
        Attached Files

        Comment


        • #5
          cherry

          Thx for information but unfortunately that is not a solution for us as we need Acrobat Reader to be default because of legacy software that does not work when Foxit Reader is default.

          Comment


          • #6
            Nico

            If you want to set Adobe as the default, please do not follow up the guidance GPO_deployment on windows 8 and windows 10.docx, not enable Foxit as default, but just set Adobe as the default.

            Comment

            Working...
            X