Announcement

Collapse
No announcement yet.

PDFs inextricably associated with Foxit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PDFs inextricably associated with Foxit

    Hi all,

    I'm running Ubuntu 18.04 and I'm trying to open a PDF in Konqueror in order to use its split-view feature, but Konqueror refuses to open PDFs except by passing them to Foxit.

    When I check the properties of a PDF file the Type is listed as 'FoxitReader document (application/pdf)'. This remains even after uninstalling Foxit.

    Any thoughts?

  • #2
    imatt

    Is it possible to provide us the Konqueror version number and make a small video that shows the problem so we could take a closer look at the issue and better advise? Thank you.

    Comment


    • #3
      cherry

      Originally posted by cherry View Post
      imatt

      Is it possible to provide us the Konqueror version number and make a small video that shows the problem so we could take a closer look at the issue and better advise? Thank you.
      Thanks for replying.

      The Konqueror version is 5.0.9.7.

      Making a video sounds like kind of a headache. I can do it, but I'd be glad if it's not necessary.

      The 'Type' seems like a strong hint as to what's going on: do you know why/how PDFs get labelled as Type: 'FoxitReader document (application/pdf)' ?

      I noticed that after uninstalling Foxit a bunch of files still showed up when I searched for 'Foxit'. Since the file association persisted after Foxit was uninstalled, I'm guessing the culprit is somewhere in these leftover files.

      P.S. sorry for multipost (now deleted); the server seemed to be rejecting the post so I kept trying.
      Last edited by imatt; 12-26-2018, 02:11 AM.

      Comment


      • #4
        Which version of Foxit Reader did you use before? Normally, all files will be removed after uninstallation. For now, you can right click on any pdf file->Properties->Open with->choose Konqueror and click on 'Set as default' button then Konqueror will be set as default program to open pdf files.

        Comment


        • #5
          richell_huang

          Originally posted by richell_huang View Post
          Which version of Foxit Reader did you use before? Normally, all files will be removed after uninstallation. For now, you can right click on any pdf file->Properties->Open with->choose Konqueror and click on 'Set as default' button then Konqueror will be set as default program to open pdf files.
          Thanks for your reply.

          The Foxit version is 2.4.4.0911. I tried 'Set as default' both before and after uninstalling. Before uninstalling, Konqueror handled the PDF by opening an instance of Foxit. After uninstalling, Konqueror failed to open the PDF and showed an error message, "KDEInit could not launch ''/home/user/opt/foxitsoftware/foxitreader/FoxitReader.sh'".

          I uninstalled using the 'uninstall' option of the Foxit maintenancetool file. The attached screenshot shows most of the remaining files (the ones out of shot are mostly in the Trash folder).

          To repeat an earlier point, the 'Type' seems like a strong hint as to what's going on. Do you know why/how PDF files get labelled as Type: 'FoxitReader document (application/pdf)'?
          Attached Files
          Last edited by imatt; 12-28-2018, 01:57 AM.

          Comment


          • #6
            imatt

            Please right-click on a PDF document, then choose Properties > Open With >choose the program you'd like to open the document with, then click "Set as Default". Please give it a try and let us know if it helps.
            BTW, Once the set as default has been re-built and you installed then uninstalled Foxit Reader 2.4.4, you should not have this issue any more. Thank you.

            Comment


            • #7
              cherry

              Originally posted by cherry View Post
              imatt

              Please right-click on a PDF document, then choose Properties > Open With >choose the program you'd like to open the document with, then click "Set as Default". Please give it a try and let us know if it helps.
              BTW, Once the set as default has been re-built and you installed then uninstalled Foxit Reader 2.4.4, you should not have this issue any more. Thank you.
              Hi Cherry,

              Thanks for your suggestion. As I wrote above in answer to richell_huang, I tried 'Set as default' both before and after uninstalling Foxit. The issue remains.

              Since several Foxit files also remain after uninstallation, and the PDF file type remains listed as 'FoxitReader document (application/pdf)', and Konqueror responds to a request to open a PDF with the error "KDEInit could not launch ''/home/user/opt/foxitsoftware/foxitreader/FoxitReader.sh", this all looks to me like the files leftover after uninstallation are continuing to label PDFs as Foxit files and prevent Konqueror from opening them natively. Do you know which file(s) would create this association?

              Comment


              • #8
                imatt ,we are sorry that we have missed your updates before. For this issue"PDFs inextricably associated with Foxit even Foxit has been uninstalled",it has already been submitted to our internal bug tracking system for our QA team to do further analysis with report ID#MACLNX-3745.We will keep you informed for any updates about this issue or you may also write back to us with this report ID#MACLNX-3745 to track its processing status.

                Comment


                • #9
                  Lisa_lee

                  Originally posted by Lisa_lee View Post
                  imatt ,we are sorry that we have missed your updates before. For this issue"PDFs inextricably associated with Foxit even Foxit has been uninstalled",it has already been submitted to our internal bug tracking system for our QA team to do further analysis with report ID#MACLNX-3745.We will keep you informed for any updates about this issue or you may also write back to us with this report ID#MACLNX-3745 to track its processing status.
                  Thanks for your reply. I'll look forward to hearing of any progress you make.

                  Comment

                  Working...
                  X