Announcement

Collapse
No announcement yet.

Forum is not secure? not running https protocol

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forum is not secure? not running https protocol

    I am told by my browser that this this site is a security risk because it is not using secure https protocol. Is this correct, or is there something I can do to improve security?
    Thanks

  • #2
    I should add that this site was hacked two years ago, probably in part because of this (hackers can intercept your login information because its not encrypted). https://www.reddit.com/r/sysadmin/comments/gdl7hk/the_foxit_software_forums_got_pwned

    Comment


    • #3
      Originally posted by Grant837 View Post
      I should add that this site was hacked two years ago, probably in part because of this (hackers can intercept your login information because its not encrypted). https://www.reddit.com/r/sysadmin/comments/gdl7hk/the_foxit_software_forums_got_pwned
      I find that this forum doesn't need any email address to register or activate the registered account, only user name and password, as such, I don't see any security risk other than the user name and password interception and exposure risk. Are hackers interested in user name and password only created for this forum? There's no financial incentive for them.

      Comment


      • #4
        Grant837 Thanks for your feedback. I've reported the issue to our team for checking by ID# SA-3576. When there is any update, I'll inform you at once. Thanks.

        Comment

        Working...
        X