Announcement

Collapse
No announcement yet.

Foxit Reader Prompting on Opening

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Foxit Reader Prompting on Opening

    Hello,

    I've recently made Foxit Reader a part of an image I've created but I'm having a problem when I log in as a standard user and run Foxit Reader it keeps prompting with the "Do you want to allow the following program to make changes to this computer?" It does this every time I open Foxit. I can circumvent this by changing the notification settings but I would prefer not to for security reasons. Other programs seem to open fine.

    Is there something I can change or adjust to allow Foxit Read to open without prompting? It seems as though the standard user doesn't have the correct privileges?

    Thanks,

    Ewan

    *****EDIT**** I for got to mentioned the OS is Windows 7 Enterprise 32bit
    Last edited by PGGW; 09-16-2014, 12:23 AM.

  • #2
    Hi PGGW,

    Please try as following:

    1. Please navigate to Foxit Reader installation folder, E.g. "C:\Program Files\Foxit Software\Foxit Reader", right-click on the FoxitReader.exe and select "Properties" ;
    2. In the popup window, select Compatibility tab, uncheck "Run this program as an administrator" under the Privilege Level; if it's greyed, click the button "Change settings for all users", uncheck "Run this program as an administrator" under Privilege Level, and then click OK, OK to exit the window.
    3. Finally try again. The UAC prompt shall not appear when Foxit Reader starts.

    Comment


    • #3
      This solution does not work for me. This just started with the 12/9 or so update. None of the EXE's have a modified property. In fact, if I just say "NO", Foxit Reader still launches. Clearly there's some other DLL or dependancy that is causing this. I really don't want to back to Adobe.

      Comment


      • #4
        Actually, to fix this, I set the program to run in Win7 compatability mode. I'm running Win 8.1 x64 with all updates.

        Comment


        • #5
          Hi guys,

          Dev team has located the cause in version 7.0.6 and compiled a new PlgDynLoader.fpi file for current workaround. You may email to support@foxitsoftware.com and indicate which software you're having to require the download link for it then replace the old PlgDynLoader.fpi to see if it works for you. Thank you.

          Comment


          • #6
            We are seeing this issue on one workstation so far. We have maybe 20 installs of reader, and this is the first report.

            Win XP SP3, prompts for RunAs each time they try to open a pdf. No difference if pdf is on local or network location.

            Using 7.0.6.1126

            I will email support regarding the recompiled PlgDynLoader.fpi.
            Last edited by slestak; 12-29-2014, 06:15 PM. Reason: Update regarding email mentioned by Cherry.

            Comment


            • #7
              Hi Slestak,

              Our Dev team also packaged the PlgDynLoader.fpi into .msi format for your deployment.
              For Foxit Reader 7.0.6: http://exchange.foxitsoftware.cn/plu...der_Reader.msi
              For Foxit PhantomPDF 7.0.6: http://exchange.foxitsoftware.cn/plu...er_phantom.msi

              For non-enterprise users, you may download the .fpi from the following for direct replacement.
              For Foxit Enterprise Reader 7.0.6: http://exchange.foxitsoftware.cn/plu...gDynLoader.fpi
              For Foxit PhantomPDF 7.0.6: http://exchange.foxitsoftware.cn/plu...gDynLoader.fpi
              For Foxit Reader 7.0.6: http://exchange.foxitsoftware.cn/plu...gDynLoader.fpi
              Last edited by cherry; 12-30-2014, 07:57 AM.

              Comment


              • #8
                I'm having the same problem. I'm running Foxit Reader 8.0 on Windows 10 Pro x64. I've had one of the IT techs at my school (I'm a teacher) enter the admin password three separate times so far. When I close and reopen the application right after she's put her password in, I don't get the "Do you want to allow this app to make changes to your device?" dialog box, but shortly thereafter it goes back to popping up every time I open the program.

                I tried to uncheck the box for "Run this program as an administrator," but it was already unchecked. I also tried running Foxit in Windows 7 compatibility mode, but no such luck. Lastly, I tried downloading the replacement PlgDynLoader.fpi from the links provided by cherry, but each of those links required a username and password to access them.

                Comment


                • #9
                  coriander

                  Please email to support@foxitsoftware.com and also include a screenshot of the problem for further processing. Thank you.

                  Comment


                  • #10
                    I had the same problem as coriander above (10-07-2016, 09:24). Foxit 8.0 on Windows 10 Pro x64 with anniversary update, both the Dutch version. Box for "Run this program as administrator" was unchecked, but when opening the program (either running from Explorer or by clicking on a .pdf-file) a UAC prompt popped up.
                    On the compatibility tab of the programs properties, I let windows problem solver (big button on that screen) fix it. It said the program was incompatible, set it to run in Windows 8 compatibility mode, and everything was fine. Rather surprising, I might say. Just hoping it stays that way.

                    Comment


                    • #11
                      Kees_B
                      Thanks for your sharing.

                      Comment


                      • #12
                        Thank you immensely....I could solve the problem with your instructions. Now PDF files open directly without asking for permission every time....even when Foxit Reader is open.

                        Comment


                        • #13
                          Thank you immensely....I could solve the problem with your instructions. Now PDF files open directly without asking for permission every time....even when Foxit Reader is open.

                          Comment

                          Working...
                          X