Announcement

Collapse
No announcement yet.

FORCE Foxit Reader to ALLWAYS use continuous mode!!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feedback FORCE Foxit Reader to ALLWAYS use continuous mode!!!!

    How do I force Foxit Reader to always use continuous mode when viewing PDF's.

    Currently, whenever I open a PDF, the page layout mode is set to whatever
    the author wanted... I WANT IT TO BE SET TO WHAT I WANT!!!

    I tried the settings suggested in the thread “Can I Do Continuous Scrolling”,
    this DOES NOT force continuous mode if the PDF file being opened wants to
    open in page mode...

    The only work around I can see so far is to set the “Preferences->History->Max Docs...”
    setting to a humungous number (say 1000) and set each document to the mode that
    I want. (which is obviously a total PITA if I want to move/re-organise any of the
    documentation I am trying to manage)...

    Thanks for reading
    (A Foxit User)
    Last edited by pdfuser; 09-17-2012, 10:05 AM.

  • #2
    Please try below settings:
    1)Tools->Preferences->History->uncheck "restore last view settings when reopening".
    2)View->Page display->check "continuous".

    Comment


    • #3
      Originally posted by richell_huang View Post
      Please try below settings:
      1)Tools->Preferences->History->uncheck "restore last view settings when reopening".
      2)View->Page display->check "continuous".
      A SWING AND A MISS...
      As I pointed out in the original post:-
      I tried the settings suggested in the thread “Can I Do Continuous Scrolling”,
      this DOES NOT force continuous mode if the PDF file being opened wants to
      open in page mode...

      So to reiterate... IF the FILE has been set to open in PAGE MODE the view setting
      in foxit are overriden (unless you set foxit to REMEMBER the settings for a given file).

      Thanks for participating
      (A Foxit User)

      Comment


      • #4
        Dear pdfuser,

        Thanks for the upate.It must be mentioned that currently our foxit reader would always read those page initial view settings preferentially to display the file in foxit reader.
        So if a PDF file has been setted by file author to show"singe page" for page layout in initial view,foxit reader will show a single page at a time for the PDF file when open it regardless what setting you choose for the page display mode in foxit reader application.
        However,I have submitted the request"Add option in foxit reader to force page layout/zoom level as user want, ignore documents' initial view settings "to our foxit reader PM team for their reference. Reported ID:READER-1114. Hope it will be implemented in future version.

        Comment


        • #5
          I'm glad someone posted this issue. Personally, I prefer documents to open in single page view rather than continuous, and "fit to page" zoom level.

          However, my understanding is that View->Page display is just another way to set the *current* display mode (the other way is from the Status bar). Intuitively, this isn't where I would expect to set the program default. There's already a place for default settings for page layout and zoom level in Edit->Preferences->Page Display. I suggest adding a check-box there that would force the selected display settings to override whatever the author set up in the document.

          It might be worth updating the request if you agree with my assessment.

          Thanks!

          Comment


          • #6
            Originally posted by ginahoy View Post
            I'm glad someone posted this issue. Personally, I prefer documents to open in single page view rather than continuous, and "fit to page" zoom level.

            However, my understanding is that View->Page display is just another way to set the *current* display mode (the other way is from the Status bar). Intuitively, this isn't where I would expect to set the program default. There's already a place for default settings for page layout and zoom level in Edit->Preferences->Page Display. I suggest adding a check-box there that would force the selected display settings to override whatever the author set up in the document.

            It might be worth updating the request if you agree with my assessment.

            Thanks!
            This request is available in Foxit PhantomPDF, with it, you can change the default read mode you need.I'd like to advise you to download it from our website for 35 days free trial.

            Comment


            • #7
              Originally posted by ginahoy View Post
              I'm glad someone posted this issue. Personally, I prefer documents to open in single page view rather than continuous, and "fit to page" zoom level.

              However, my understanding is that View->Page display is just another way to set the *current* display mode (the other way is from the Status bar). Intuitively, this isn't where I would expect to set the program default. There's already a place for default settings for page layout and zoom level in Edit->Preferences->Page Display. I suggest adding a check-box there that would force the selected display settings to override whatever the author set up in the document.

              It might be worth updating the request if you agree with my assessment.

              Thanks!
              I feel your pain foxit pdf viewer is not user friendly. I do not think the people who created the PDF use it in everyday life or they would know.

              Comment


              • #8
                Originally posted by richell_huang View Post
                Dear pdfuser,

                Thanks for the upate.It must be mentioned that currently our foxit reader would always read those page initial view settings preferentially to display the file in foxit reader.
                So if a PDF file has been setted by file author to show"singe page" for page layout in initial view,foxit reader will show a single page at a time for the PDF file when open it regardless what setting you choose for the page display mode in foxit reader application.
                However,I have submitted the request"Add option in foxit reader to force page layout/zoom level as user want, ignore documents' initial view settings "to our foxit reader PM team for their reference. Reported ID:READER-1114. Hope it will be implemented in future version.
                Hi Richell,

                it's pdfuser (the original poster) here, sorry for the delay, been busy the last month. I am gratified that you guy's understand MY issue with your otherwise FINE product. I'm not saying the user settings MUST override the author’s settings BUT it would be nice to have the OPTION to make the ‘USER DEFAULT’ setting be a ‘MANDATORY DEFAULT’ setting. Thank you for listening and raising the issue; if it gets implemented I believe it will put the icing on a truly excellent cake.

                Thanks for participating
                (A Foxit User)

                Comment


                • #9
                  Originally posted by pdfuser View Post
                  Hi Richell,

                  it's pdfuser (the original poster) here, sorry for the delay, been busy the last month. I am gratified that you guy's understand MY issue with your otherwise FINE product. I'm not saying the user settings MUST override the author’s settings BUT it would be nice to have the OPTION to make the ‘USER DEFAULT’ setting be a ‘MANDATORY DEFAULT’ setting. Thank you for listening and raising the issue; if it gets implemented I believe it will put the icing on a truly excellent cake.

                  Thanks for participating
                  (A Foxit User)
                  I also hope it will be implemented in future, any update, we will post here.

                  Comment


                  • #10
                    exceptional site post. I am going to bookmark forums.foxitsoftware.com and check out a lot more often. I really like the website template regards

                    Comment


                    • #11
                      dear Foxit please add this feature! It should be possible to set the reader to always open all documents in the chosen preferred mode

                      Comment


                      • #12
                        Originally posted by charonme View Post
                        dear Foxit please add this feature! It should be possible to set the reader to always open all documents in the chosen preferred mode
                        Please try below settings:
                        1)Tools->Preferences->History->uncheck "restore last view settings when reopening".
                        2)View->Page display->check "continuous".

                        For overriding default mode, it is available in Foxit PhantomPDF, with it, you can change the default read mode you need.I'd like to advise you to download it from our website for 30 days free trial.

                        Comment


                        • #13
                          More than a year has passed since the initial request to "Add option in Foxit reader to force page layout/zoom level as user want, ignoring documents' initial view settings".

                          ​Continuous scrolling is a must for a good PDF reader.

                          When will this feature be added into Foxit reade?

                          Comment


                          • #14


                            Hello all,

                            I do not make a practice of responding, let alone taking the time to sign up and register for a site in order to make a post, but in the spirit of the Open Source community, and all of the quiet gentle suffering that has endured within this post, I'll make an exception. I made some posts in a few currency trading forums when I was first getting started from 2007 or so, and from time to time someone adds or inquires about the topic(s). Nevertheless, my recent rampage into this Foxit Continuous scrolling issue led me to a discovery. .. That one can Navigate to the "VIEW" tab, and at about the end to the Right, you'll see the "AutoScroll" option. I read a Lot of PDFs, or access them, daily, for academic purposes, and find it a major annoyance when the page sticks, and will only turn one full page at a time... while I am trying to spend time at the bottom to top of the next page... You get the picture.

                            Anyhow... I click on the "AutoScroll" option, and was pleasantly surprised to find that the page will scroll itself freely, while you can adjust the speed, respectively, with the up and down arrows. "Nice!"... I thought, since I am also a big fan of Text to Speech, as it lightens my work load. This also, seems to have fixed the Continuous Scroll conundrum... So, when I close and re-open the document, it does indeed return back to the stuck mode, as 'pdfuser' member has copiously noted above. So, to fix this, you will need to in essence 'double click' on "AutoScroll" each time you open a pdf.

                            Foxit seems to have stepped over the "Add option in foxit reader to force page layout/zoom level as user want, ignore documents initial view settings" request which was mentioned above, in favor of portability. Seems like folks are tripping over themselves to make things more 'intuitive' to the point of neglecting the details in forums like these. I am surprised that these issues do not overlap in the forums, but alas I hope this helps... Cheers!

                            Comment


                            • #15
                              After reading this post, I've been able to figure out to enable and then disable "autoscroll" and then click "fit width" on documents that have been set up to display funny like that. There's no reason I'd ever want to jump to the next page when I've accidentally scrolled one line past the bottom of a page. That view mode is not ever useful to me. I'd also really like to see a way to keep this setting without doing it every time I open a document. At least I know how to change it now.

                              Comment

                              Working...
                              X