Announcement

Collapse
No announcement yet.

Foxit reader -> proxy -> sharepoint: error: integrateWithSP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Foxit reader -> proxy -> sharepoint: error: integrateWithSP

    I try to edit a .pdf file with FoxIt Enterprise Reader 5.5.0.1227.
    The .pdf file is stored in a sharepoint 2010 document library.

    On the sharepoint 2010 server in
    Drive:\Program Files\Common Files\Microsoft Shared\Web server extensions\14\Template\Xml\DOCICON.XML.
    the following line is added: <Mapping Key="pdf" Value="pdficon.gif" OpenControl="FoxitPhantomPDF.OpenDocuments" />

    If I open the .pdf file with with FoxIt Enterprise Reader 5.5.0.1227 on our test sharepoint 2010 environment it works as it should.

    If I open the .pdf file with with FoxIt Enterprise Reader 5.5.0.1227 on our production sharepoint 2010 environment I get an error: "IntegrateWithSP" (see screenshot attached) -> the .pdf file is not opened (The FoxIt reader window is open though).
    The only difference as far as I know is that the sharepoint production server is in our DMZ -> I con only reach it via proxy.
    We have tested http communication with fiddler (http trace tool) and it seems no request is sent by FoxIt when it has to go through the http proxy.

    What can we do to debug this further?
    Best regards from cloudy Vienna
    Dieter
    Attached Files
    Last edited by 50watt; 02-18-2013, 01:38 PM.

  • #2
    This situation has been forwarded to our QA team for further analysis, report id:45520, any update, i will let you know.
    BTW, what is the OS?

    Comment


    • #3
      OS: Windows 7 Enterprise, Service Pack 1

      Comment


      • #4
        Our current Sharepoint Plugin 1.0 does not support proxy environment so it causes the error, our Dev team will work Sharepoint Plugin 2.0 in future.
        For now, please try below workaround.
        Either not add <Mapping Key="pdf" Value="pdficon.gif" OpenControl="FoxitPhantomPDF.OpenDocuments"

        Or disable registry key bEnableSharePointFeatures(under HKEY_CURRENT_USER\Software\Foxit Software\Foxit Reader 5.0\Preferences\Others) by setting it to value 1

        Comment

        Working...
        X