Announcement

Collapse
No announcement yet.

Customizing preferences in FF

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Customizing preferences in FF

    Hi, I'd like to be able to add buttons like rotate when previewing a pdf in firefox. In Foxit's main application, I can customize it nicely. In FF, it is very limited... to rotate a page, I have to either choose a different platform to view (instead of preview in Foxit) or use Foxit's main app to view it outside of the browser.

    Not sure if I've installed the main reader and the plug-in correctly. If I go to Firefox's tools->Options -> Application menu, there's an FDF reader (for Foxit files) that has "Use Foxit Reader Plugin for Mozilla" in the drop down.

    But under the pdf, my choices are: "Preview in Firefox", "always ask", "save", then a separator followed by "Foxit Reader," and another pdf reader i have installed.

    The Foxit Reader option will load the file in the main Foxit reader application, not in the browser, even if "open in browser" is set in the main Foxit application's preferences under "File associations". Similar for the other installed reader.

    It almost seems like the "Foxit reader plugin for Mozilla" that shows up in the FDF file association should be under pdf, but I'm not sure if that's true, or if it would actually help.

    Any thoughts on how to get more functionality on reading pdfs in FF?

    P.s. This forum forces the user to select one of the prefix options, but I'm not sure this is really a bug... more of a question.

  • #2
    If it helps, here are the versions I'm using. Reader was installed earlier this week, FF Plugin installed today.
    Foxit Reader version: 5.4.5.0124
    FF Plugin version: 2.2.3.111

    Comment


    • #3
      Hi mjdeez,

      Since the toolbar setting in Foxit Reader will synchronize the toolbar settings when you try to open PDF document from within browser. I encourage you to do as following:
      1) Open Foxit Reader->right-click on the blank area of the toolbar->'Customize Toolbars'->'Toolbar Setting'->tick 'Rotate Right' and 'Rotate Left' under View to make sure that they appear on the toolbar.
      2) Tick 'Display PDF in Browser' and make Foxit Reader your current default Reader;
      3) Open the PDF document online from within Firefox, then right-click and tick 'View', the rotate buttons should appear on the toolbar until you uncheck 'View'.

      Comment


      • #4
        For enabling the rotating option during preview or normal mode. Choose option from menu bar view->rotate->clock wise/counter clock wise or can use the shortcut buttons. For clock wise press Shift+Ctrl+plus(+) and for counter clock wise shift+ctrl+minus(-). And the Tick 'Display PDF in Browser' and make Foxit Reader your current default Reader.This will help you to open all your PDF documents in foxfit reader.

        Comment


        • #5
          Originally posted by cherry View Post
          Hi mjdeez,

          Since the toolbar setting in Foxit Reader will synchronize the toolbar settings when you try to open PDF document from within browser. I encourage you to do as following:
          1) Open Foxit Reader->right-click on the blank area of the toolbar->'Customize Toolbars'->'Toolbar Setting'->tick 'Rotate Right' and 'Rotate Left' under View to make sure that they appear on the toolbar.
          2) Tick 'Display PDF in Browser' and make Foxit Reader your current default Reader;
          3) Open the PDF document online from within Firefox, then right-click and tick 'View', the rotate buttons should appear on the toolbar until you uncheck 'View'.
          Originally posted by lucipherphill View Post
          For enabling the rotating option during preview or normal mode. Choose option from menu bar view->rotate->clock wise/counter clock wise or can use the shortcut buttons. For clock wise press Shift+Ctrl+plus(+) and for counter clock wise shift+ctrl+minus(-). And the Tick 'Display PDF in Browser' and make Foxit Reader your current default Reader.This will help you to open all your PDF documents in foxfit reader.
          I tried both of these suggestion but it doesn't work. I think the problem is my plugin is not installed correctly. If in FF, you go you Tools -> Options -> Applications, what do you have under "PDF"? I do not have "Use Fox it reader plugin..." under PDF. For some reason it is not there. I do have it under "FDF" for Foxit documents but this doesn't help me.

          I tried uninstalling / reinstalling both Foxit and the plug-in and it did not behave any differently.

          Comment


          • #6
            Please run firefox, go to tools->options->application, find PDF document, see which action is selected. (Normally it shall be "Foxit Reader plugin for Mozilla", but if Adobe is installed, will be Adobe Acrobat (in Firefox)). And go to Tools/Addons/Plugins, be sure Foxit Plugin is enabled.
            And if you also find "Portable PDF Format", please also set it to "Foxit Reader plugin for Mozilla".

            Comment


            • #7
              Originally posted by richell_huang View Post
              Please run firefox, go to tools->options->application, find PDF document, see which action is selected. (Normally it shall be "Foxit Reader plugin for Mozilla", but if Adobe is installed, will be Adobe Acrobat (in Firefox)). And go to Tools/Addons/Plugins, be sure Foxit Plugin is enabled.
              And if you also find "Portable PDF Format", please also set it to "Foxit Reader plugin for Mozilla".
              "Foxit Reader for Mozilla" is not available to me under the Firefox -> tools -> options -> applications menu for pdf file associations. I don't know why. It IS available under the FDF file association, but this doesn't help me with pdf files.

              Comment

              Working...
              X