Announcement

Collapse
No announcement yet.

Certain Annotations Not Displaying

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Certain Annotations Not Displaying

    Foxit ActiveX Control 5.3.0.522 (Pro Version)
    SAP PowerBuilder 12.5

    I am trying to programmatically annotate a PDF with a graph background to display retrieved data as a PolyLine or a Pencil annotation (with data points as vertices). The default PolyLine is displaying properly, however SetPolygonVertices fails. The opposite is true for Pencil annotations where SetPencilVertices is passing but the default pencil annotation is not showing up despite returning a non-null object. Examples of how I'm initializing the pencil and polyline annotations are displayed below:

    ole_line = ole_annot.AddAnnot(rs_null,"Pencil",0,0,lg_page_wi dth,lg_page_height) //doesn't display but passes

    lg_index = ole_line.SetPencilVertices(REF lg_ref,6) //passes

    vs

    ole_line = ole_annot.AddAnnot(rs_null,"PolyLine",0,0,lg_page_ width,lg_page_height) //displays

    lg_index = ole_line.SetPolygonVertices(REF lg_ref,6) //fails

    Does SetPolygonVertices not apply to PolyLine annotation subtypes? Is there a reason for Pencil annotations to not be displaying but PolyLines, Lines, Arrows, Ellipses, etc are displaying fine? Thanks in advance.

  • #2
    cchiasson ,Thanks for your post.For SDK related questions,please help to write your query to adv.support@foxitsoftware.com or submit a ticket from our online support ticket submit system below:
    https://tickets.foxitsoftware.com/create.php
    And then our SDK department technical support will get in touch with you.

    Comment

    Working...
    X