No announcement yet.

Cannot Sign my documents after Phantom Editor trail.

  • Time
  • Show
Clear All
new posts

  • Cannot Sign my documents after Phantom Editor trail.

    Cannot Sign my documents after the Phantom Editor trail. I removed all pdf readers from my laptop, restarted it, and installed the free one. Now it says your trail has expired.

  • #2
    Sorry for the trouble. You must use Foxit eSign to sign a document, which is newly integrated with the program and requires a separate purchase. You can disable Foxit eSign and use Fill & Sign function instead.
    In version 12, you can click Help -- About Foxit Plug-ins and turn off Foxit Sign plug-in, then click OK and restart the program to apply change. After that, you can use Protect - Fill & Sign feature to sign a file.
    In version 11.2, you can click Switch to Ink sign icon under Foxit eSign tab and use Fill&Sign. If you would like to disable it, please go to File > Preferences > PDF Sign and click the option 'Disable Foxit eSign service'.