Announcement

Collapse
No announcement yet.

Viewing pdfs in browser

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Viewing pdfs in browser

    I am not able to view pdfs within IE11 using Foxit Phantompdf 9.4.1. I have tried to disable and enable the plugin and it seems that this does not make a difference. If I use Mozilla Firefox which uses its own internal pdf viewer the document will appear fine. This is on a Win 8.1 machine. Most machines are configured to use Internet Explorer 11 and have Foxit as the default viewer.

    Any help is appreciated.

  • #2
    rjlasb18

    Two steps:
    1) Please go under "File"->"Preferences"->"File Associations"-"Advanced"->Tick the "Include Browser when setting default PDF Viewer";
    2) Click on "Make Default PDF Viewer".

    Since version 6.x, these two options are bundled together to take effects. Once you make change to "Include Browser when setting default PDF Viewer", you need to click on "Make Default PDF Viewer" as well. Please give it a try and let us know if info above helps. Thank you.

    Comment


    • #3
      cherry Foxit is already the default browser and the "Include Browser when setting default PDF Viewer" is already checked.

      There are times where it shows like it is downloading the file to open in the browser, other times it will just display a blank screen.
      Last edited by rjlasb18; 02-12-2019, 04:20 PM.

      Comment


      • #4
        rjlasb18

        Please try to un-associate and re-associate the "Display PDF in Browser" as following and see if it helps:

        1) Please open Foxit Reader, then go under "File"->"Preferences"->"File Associations"->"Advanced", uncheck "Include browser when setting default PDF viewer" then click on "OK".
        2) Under "File Associations", please click on "Restore File Associations";
        3) Again, please go under "File"->"Preferences"->"File Associations"->"Advanced", check "Include browser when setting default PDF viewer"->"OK" then click on "Make Default PDF Viewer" as default PDF Reader. 

        After having made settings above, you may try to open the online PDF from browser again and see if it helps. If it doesn't help, please try the following:
        1) Please open IE->go to 'Tools'->'Advanced'->find 'Security' from the list-> uncheck 'Do not save encrypted pages to disk';
        2) Please clear the caching of your IE browser;
        3) Please right-click IE browser and choose "Run as Administrator" and see if it helps;
        4) How about the result if you open IE->go under "Tools"->check "Compatibility View" then trying to open the PDF document from within IE?
        5) Open your registry editor, find HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth and check if the value is set 1.

        Comment


        • #5
          The first set of instructions did not work.

          'Do not save encrypted pages to disk' was already unchecked and I have tried to clear the cache before but that does not work either. Also, compatibility view did not work and I don't want to run as administrator because this is a organization wide issue so not everyone can or should run as admin. The reg key does not exists.

          Comment


          • #6
            rjlasb18

            Sorry to know that it doesn't help. Is it possible to provide the following info?
            1) Can you open this test link fine? The link: http://cdn01.foxitsoftware.com/pub/f...ration_7.2.pdf
            2) Which URL did you try to open from within the IE browser?
            3) A screenshot of the problem;
            4) Please right-click on "This PC/Computer" then open Properties to check the detailed OS version number.

            Thank you. If the URL is confidential, please email the info to support@foxitsoftware.com. [Attn: Cherry] Thank you.

            Comment


            • #7
              rjlasb18 ,I apologize for the trouble.To make Foxit PhantomPDF browser plugin to be able to open online PDF file within IE web browser,it asks for administrator right for writing registry values.
              So would you please try to open your Foxit PhantomPDF with administrator right and then try to do un-associate and re-associate the "Display PDF in Browser" again to see if it will helps:
              1):Right click on "Foxit PhantomPDF" purple icon on your desktop,select "run as administrator" to launch your Foxit PhantomPDF application. (There would be a UAC message pop-up which asks for administrator right,please click on "Yes" there to allow it to run as administrator right).
              2): Please open Foxit PhantomPDF, then go under "File"->"Preferences"->"File Associations"->"Advanced", UNCHECK "Include browser when setting default PDF viewer" then click on "OK" to close the "Advanced" window.
              3):Click on "Make Default PDF Viewer" button under the "File associations"tab in preferences dialog box.
              4):Click on "Advanced" button to open the "Advanced..."dialog box again, CHECK "Include browser when setting default PDF viewer"->"OK" then click on "Make Default PDF Viewer" button,click "OK" to close preferences dialog box.
              I have also recorded a animated gif file(how to.gif) to let you know the whole procedures that we need to do for your reference.

              If the above procedures still don't make any difference,we suggest submitted feedback to support@foxitsoftware.com (Attn:Lisa) and indicate this thread link,then our technical support team will further work with you on this issue.
              Attached Files

              Comment


              • #8
                cherry
                1. I tried this test link and all it opened was a white blank page
                2. test link and other
                3. White blank page
                4. Windows 8.1 Pro not sure what detailed OS you are looking for.

                Comment


                • #9
                  Lisa_lee
                  I used to be able to view PDFs in the browser in a earlier version. So I don't understand why the application needs the administrative rights. The application was installed with administrative rights which should be carried over with updates applied.

                  Just for sake of testing I tried all those steps and ran the application under administrative credentials and there was still just a blank white page. Just puzzled how this is only effecting my PC unless many people are not on 9.4.1

                  Comment


                  • #10
                    rjlasb18

                    1) Please drag a PDF document directly into the IE browser and see if it could be displayed fine.
                    2) If not, please import the attached registry into your system then try to open the link to the PDF document and see if it helps; Please drag a PDF document into IE again and see if the PDF document is opened fine.

                    If the registry import doesn't help either, please email to support@foxitsoftware.com to get a plugin with log to further analyze.

                    Comment


                    • #11
                      I have a printer and whenever I print pdf it shows oxe5 epson error problem which was more irritating and also it takes much more time to solve this problem. I am suffering from this problem every time whenever I use my printer. after that, I go to https://www.epsonsupport247.com/epso...e-0xe5-solved/ website and got the proper solution.

                      Comment


                      • #12
                        cherry Adding the registry key did not work either.

                        Comment


                        • #13
                          rjlasb18 ,As cherry has mentioned before,if the registry import doesn't help either, please help to email to support@foxitsoftware.com to get a plugin with log to further analyze.
                          Please indicate this thread link when you email to us.

                          Comment


                          • #14
                            Lisa_lee Sent email to support on 3/4 [FOXIT #262756] Have not heard anything yet.

                            Comment


                            • #15
                              rjlasb18 ,I apologize for the delay in responding since we are inundated with lots of emails and calls each day in these days.I have already sent you the plugin with log feature in ticket 262756 and I will keep on following up this issue for you in ticket 262756.

                              Comment

                              Working...
                              X