Announcement

Collapse
No announcement yet.

PhantomPDF takes a long time to save a file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PhantomPDF takes a long time to save a file

    When saving a large pdf file, the "Discarding Invalid Objects…" step takes a long time to finish on PhantomPDF. This delay does not occur on the FoxIt PDF reader.

    I believe it would be an improvement if this step could be either skipped or disabled when not needed. Due to this issue, it takes me about a minute to save some of the larger files, even if the change in question is something as simple as adding a bookmark. If this option already exists, I would be thankful if someone can tell me where it is, as I've been unable to find it.

    Tested on:
    Windows 10 Pro x64 (Build 17134)
    Phantom PDF Business 9.2.0.9297.

    Test PDF is a 300 MB pdf, linked here.

    After adding a single bookmark, the time required to save the file (tested by saving the same file on the same computer) is:
    PhantomPDF: 1 min 36 sec
    FoxIt PDF Reader: 8 sec

  • #2
    mchen96

    Sorry for the inconvenience. The issue has been submitted to our team for further investigation, any updates, I will keep you informed. Report ID:QCPHANTOM-19364.

    Comment


    • #3
      @lyndi_wu

      I have the same problem--specifically: unlike Acrobat or PDF Studio Pro, Foxit Phantom 9.6.0.25114 takes about 30 seconds to save a large PDF (180 MB)

      Steps to reproduce the problem:
      1. Upgrade from Foxit Phantom PDF Business (Licensed) 9.5.0.20723 to 9.6.0.25114 on Windows 10 10.0.17763 Build 17763
      2. Open this PDF: https://www.dropbox.com/s/rm1v6fd01l...-save.pdf?dl=0
      3. Make a change (e.g., add a bookmark)
      4. save the file (takes about 30 seconds on my i7 PC)

      You see acceptable (normal) speeds of about 5 seconds if you try with the following:
      1. Foxit Reader (not Phantom) 9.6.0.25114
      2. Foxit Phantom 9.5.0.20723 (Express or Licensed Business)
      3. Adobe Acrobat Pro X
      4. PDF Studio Pro 2019

      So far, I have reproduced this on 3 hosts / computers:
      1. Parallels in Macbook Pro
      2. VM on bhyve
      3. Microsoft Windows Surface Pro 3
      Last edited by mellowyellow; 07-25-2019, 12:11 AM.

      Comment


      • #4
        mellowyellow Sorry for the inconvenience. I have forward your information to QA team for analysis under the same bug ID#QCPHANTOM-19364. thanks

        Comment


        • #5
          amanda_liang Any update? It's been half a year. I am paying for the software. Please address this. I'm not alone.

          Comment


          • #6
            mellowyellow Sorry for the inconvenience the issue caused. I've sent out another reminder to our corresponding engineer and we'll keep you posted here. Or you may email to [email protected] with this Report ID#QCPHANTOM-19364 to track the processing status any time.

            BTW, please also go to File->Preferences->Documents->Save Setting->to check if you may have checked "Save as optimizes for fast web view". If yes please uncheck it.
            The most current version of Foxit PhantomPDF is version 9.7.1, you may update to it and try again. Thank you.

            Comment


            • #7
              mellowyellow

              Is it possible to provide us a copy of the PDF document that you encountered the problem with again? Thank you.

              Comment


              • #8
                Originally posted by cherry View Post
                mellowyellow

                Is it possible to provide us a copy of the PDF document that you encountered the problem with again? Thank you.
                Any update? The link I posted above is still valid. I just tested it. It still triggers the issue too, including in Phantom Version: 9.7.1.29511

                Comment

                Working...
                X