Announcement

Collapse
No announcement yet.

Problems with Managing Form Fields

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Problems with Managing Form Fields

    Hello all,

    I have moved across an Adobe PDF file that has a number of form fields.
    Because I batch export the data into CSV data table before going directly into an excel sheet, the sequence of form fields is not one of the presets (i.e.Order tab by rows/column/ or structure).
    I now need to insert a new form field i.e. not at the end.

    I create the form field, automatically gets added to last position. I need it it to export at a specific point in the form's data.

    So I manually change its order (from the end) by moving it up to where I need it by using the 'Manage form field' tab on the side to gain access the order. And do a select and single item drag to the right spot.

    Then I save it. Close and reopen.... It has NOT moved from the end in the sequence. It is right back at the end in the tab order sequence.

    HELP!!

    BTW have looked in forums, haven't seen anything answering this. I'm doing what I am supposed to per the manual's instructions p.214 (Foxit PhantomPDF ver 9.6)
    I've also tried everything under the sun to see if I can get it to work.

    I have attached a cut down version of my form. I renamed the problematic form field that will not stay set as "NEW-ONE-ADDED"... It will be the last one on the Manage form field, where it always ends back up at after you re-open the file.

    Appreciate any advice as to what is wrong here.

    Dan
    Attached Files

  • #2
    DanJunk

    Please try to use Save as after you've changed the order of specific forms, then the new form will include the form fields with correct order. Please give it a try.
    Regarding why the manual changing order cannot be saved, I've escalated it to our internal bug tracking system for processing. Report ID#QCPHANTOM-20850.
    Thank you.

    Comment


    • #3
      Did not fix, did the same.

      I opened the file
      I moved up the the "NEW-ONE-ADDED" to earlier in the sequencing
      I clicked on another to change the focus
      I 'Saved As' with a different filename
      Closed down the program
      Started program again, and opened the new file just saved
      ==> the "NEW-ONE-ADDED" was right back down at the end of the sequence

      Here's what happens when I use the 'Set Order' option. Essentially it resets to the new order and stays---except the "NEW-ONE-ADDED" which gets pushed right back to the bottom.
      Click image for larger version

Name:	Form-Order-problem.png
Views:	186
Size:	121.7 KB
ID:	174611
      Unfortunately, the sequence needs to be custom not one of the presets offered.






      Comment


      • #4
        DanJunk Sorry for the inconvenience. The issue was reported to QA team for analysis. Any updates will inform you. thanks

        Comment


        • #5
          DanJunk

          Quick update of "Report ID#QCPHANTOM-20850: Problems with Managing Form Fields: The order of the field can not be saved", the issue has been fixed internally and will be included in the next formal release of version 9.7.1 if everything works fine. If you're interested in testing out the internal version, please email to [email protected] with your request.

          Thank you.

          Comment


          • #6
            Cherry,

            I'm now using the PhantomPDF 9.7.1.29511 software build.
            The problem continues to exist.
            I have rebuilt the PDF from the ground up, and now at the end it will not let me change the order of some of these.
            Same problem as I outlined above.

            Please advise if your suggested version is newer than this one...

            This bug is stopping me from completing the project. If I can't sequence the field output so I can drop it into my excel sheet without massive cut and pasting it doesn't really help me automate my work.

            Dan.

            Comment


            • #7
              Dan - As a workaround, try the following:

              1. Set the fields in the order that you want
              2. Duplicate the fields to another page
              3. Delete the fields from the original page
              4. Now duplicate the fields back to the original page (if you didn't move the fields around or re-format anything, then the fields should go right back into their original position)
              5. Delete the fields from the other page

              Now test the tab order, hopefully this will work for you (it worked for me).

              It's very disappointing that this issue is still around almost a year after it was reported. I really did expect better from FoxIt...

              Comment


              • #8
                DanJunk Sorry for the inconvenience. I have made test of your pdf in version 10.0 of Foxit PhantomPDF. the field "New One Add" able to change location and save successfully. Can you please upgrade Foxit and check result? tks.

                Comment


                • #9
                  Judah, thanks I will try that.

                  Amanda, unfortunately software updating is not in my hands. I have passed on your recommendation to the government's IT department. Hopefully they will do the update at some time in the future.

                  Dan.

                  Comment

                  Working...
                  X