Announcement

Collapse
No announcement yet.

Allow Users to Adjust Font Size in Form Field

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Allow Users to Adjust Font Size in Form Field

    How can I allow users to change the font size in a form field when they're typing data? In the past, I was able to accomplish this by enabling Allow Rich Text Formatting in the field properties, but that doesn't seem to be working in PhantomPDF 9.7. The Font options on the Edit tab are grayed out. There is no security on the form. I can open the same form in Acrobat and Reader, and I'm able to change the font size. I'm sure I'm missing something obvious. Anyone have a solution?

  • #2
    Just follow these steps -
    1) Right-click on the selected text and click "Properties" from the box that appears.
    2) Click the "Text" tab within the Properties box and select the desired font size from the Font Size options.
    3) Click "OK" to implement the changes.

    I hope this will help!

    Comment


    • #3
      Sorry, I should have been clearer. My users don't want to mess with form field properties. I want a way to access the font properties bar from the Edit tab. Thanks!

      Comment


      • #4
        Muffle

        Currently if we want to adjust font size in Form field, we'll have to open the Properties of the Text Field, then go to Appearance to change. I've forwarded your comments as suggestion so our Product team could consider to add a "Text Style" option when right-clicking on the filled text in the form field. Suggestion ID#:PHANTOM-11124.
        For now, I'm wondering if using Typewriter tool to fill out the form would fufill your needs, the users could simply go to Commment->Typewriter then input the text at desired format. Thank you.

        The Fonts options under "Edit" menu is for changing the the fonts options for the text objects in the PDF documents, not for the fonts options in Form Fields.

        One more thing, you mentioned that "In the past, I was able to accomplish this by enabling Allow Rich Text Formatting in the field properties, but that doesn't seem to be working in PhantomPDF 9.7", if we set "Allow Rich Text Formatting", we're able to copy the text with formatting from Word (or any other software) to the Text Field in PDF document. Please let us know if it is working in version 9.7 on your side. Thank you.

        Comment


        • #5
          Learnt it the hard way. When you create a form text field . Modify the font size and the font for that field. Then keep copying the same field to add more fields in the form. The text field name will keep incrementing and the font properties will continue to remain what you had defined in the first form field. If you need to change the font size depending on spacing, you can just edit the properties of that field and modify it. Hope this helps until we get the option to set global font size and font .REMEMBER : you have to define the size and font for the first field and copy/pasting subsequent fields.

          Comment


          • #6
            vinod2210 ,To change the font size depending on spacing,please select "Auto" as Font size under "Appreance"tab in "Text Field Properties" window.
            Click image for larger version

Name:	auto.png
Views:	201
Size:	15.1 KB
ID:	176865
            For the global font size,do you mean that you want to get a default font size for all text fields? If so,please set the font propreties you like in the first added form field,select "Form"tab>'"Select>Select Annotation" tool,right click on the first form field and select "Use current properties as New defaults" in the pop-up context menu.Then try to add form fields again, you will find that the newly added form fields would all inherit those properties automaticallly.
            Click image for larger version

Name:	default.png
Views:	103
Size:	36.6 KB
ID:	176866


            Comment


            • #7
              @lisa_lee : Thank you for the insight.

              Comment

              Working...
              X