Announcement

Collapse
No announcement yet.

macOS: FoxitPDFReaderUpdateService consumes unacceptable amount of CPU

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • richell_huang
    replied
    Thank you for sharing it.

    Leave a comment:


  • camilasaunder89
    replied
    Hi, You can try the below methods to solve this issue:
    1. Disable extraneous processes
    2. Defragment the hard drives of the affected computers on a regular basis
    3. Abstain from running too many programs at once
    4. Remove any programs your employees don't use from your company's computers
    Also, you can try Mac Uninstallers to remove apps completely and fix cpu usage.


    Leave a comment:


  • lyndi_wu
    replied
    MacBildung

    Sorry again for the trouble, and thank you for your kind understanding.

    Leave a comment:


  • MacBildung
    replied
    Thank you for the clarification, cherry. We are very much looking forward to a fixed version.

    After five days, the constant CPU load of the FoxitPDFEditorUpdateService process on my Mac has now risen to 15-16%, and my Mac has become noticeably warmer. So it does indeed look like the process just keeps consuming more and more CPU resources until the Mac's fans have fully turned into jet engines and/or the Mac has become unresponsive. I will now end this experiment and remove the FoxitPDFEditorUpdateService binary as detailed by Roy_Chen.

    Leave a comment:


  • cherry
    replied
    MacBildung

    What Roy suggested was a temp workaround for this issue. The developers are working on this issue and hopefully it could be fixed soon. We'll update the status here as well when it is fixed. Thank you.

    Leave a comment:


  • MacBildung
    replied
    Thank you for the swift reply, Roy_Chen.

    Just to clarify, though: The steps you described above disable PDF Editor's automatic update check, right? Meaning users would no longer get notified about updates that often contain critical security fixes, like the remote code execution vulnerabilities that were fixed in the most recent release of PDF Editor, correct?

    Having to choose between letting your Mac slowly turn into a space heater and not receiving critical security updates is not a great situation to find yourself in. I sincerely hope there will be a better option soon and the issue will actually get fixed. Thanks again for your support in this matter.

    Leave a comment:


  • Roy_Chen
    replied
    MacBildung
    We apologize for any difficulty using Foxit Software.
    Here is a workaround you can follow up to see if it works:
    1.Open Finder
    2.Tap Command+Shift+G to get into system directory
    3.Input /Library/Application Support/Foxit Software/FoxitService
    4.You will see two progress (attached 1), please rename that two progress
    5.Reboot your computer, then access to the same location you will find that those two can be deleted.
    Check here for that video.
    Attached Files

    Leave a comment:


  • MacBildung
    replied
    It's a bit disheartening to see that this bug is still not fixed, even though it was reported 2.5 months ago.

    We upgraded our Mac users to PDF Editor 11 two days ago, so I just became aware of this bug. It looks like the issue is even more severe that Axel Buchner's report suggests:

    When I first noticed the permanent CPU load of the FoxitPDFEditorUpdateService process on my MacBook Pro, it was fluctuating between 2 and 3%, which is already far too much, especially for laptop users. But even more problematic is that the load seems to steadily increase over time: After two days, it's now sitting at a staggering 8-10%, with no end in sight.

    The problem seems to be pretty universal: Everyone of our Mac users that I asked sees it too (on some Macs, the CPU load is already up to 12%).

    Removing the update service, as Axel Buchner detailed above, is not an option for us. The whole reason why we upgraded from PhantomPDF 4 to PDF Editor 11 was so that our users would receive automatic security updates again.

    I would therefore like to strongly encourage you to fix this issue as soon as possible. We've been pretty happy with the Mac versions of PhantomPDF until now, but this is really starting to look like a deal breaker.

    If you need any additional information, please let me know.


    Technical details:
    • Foxit PDF Editor 11.0.1.0719
      • installed via the PKG installer from the website
      • we do not use the Foxit Admin Console
    • macOS 11.5.1 (20G80)
    • MacBook Pro (2020, Quad i5, 16GB RAM)

    Leave a comment:


  • Roy_Chen
    replied
    Axel Buchner
    We apologize for any difficulty using Foxit Software, this issue had been submitted to our Develop team for optimization, and update the severity to High, will inform you as soon as possible, thanks for your patience.

    Leave a comment:


  • Axel Buchner
    replied
    I am sorry to have to report that the latest version of Foxit Editor for Mac (11.0.1.0719) still has the same problem: around 2.3 % of CPU usage is too much (and much more than the idling Foxit Editor itself at around 0.5 %). Please fix this issue quickly. We cannot afford such a significant drain of our batteries.

    Leave a comment:


  • lyndi_wu
    replied
    Axel Buchner

    Thank you for your sharing on the workaround. Any update on this case, we will keep you posted.



    Leave a comment:


  • Axel Buchner
    replied
    For those who want to stop the wasting of battery capacity by FoxitPDFEditorUpdateService or FoxitPDFEditorUpdateService or both, here is a workaround until the Foxit developers solve this problem:
    1. On macOS 11, go to your global Library folder (typically: Macintosh HD/Library, this is not the Library folder in your user directory but rather the library folder in which things are stored that affect all users of your computer).
    2. In your Library folder, go to a folder called Application Support
    3. Find the folder Foxit Software which contains a folder called FoxitService which contains the file FoxitPDFEditorUpdateService or FoxitPDFEditorUpdateService or both; these are the apps that seem to cause the problem.
    4. Delete the folder called Foxit Software (i.e., Macintosh HD/Library/Application Support/Foxit Software).
    5. I am not sure whether you need to empty your trash but I did it.
    6. Restart. This solved the problem for me.

    Leave a comment:


  • Roy_Chen
    replied
    Axel Buchner
    Thanks for reporting! Already submitted your issue to our QA/Dev team as report id#MACLNX-10569, will forward an update the moment I have it.

    Leave a comment:


  • Axel Buchner
    replied
    (1) I had installed both, Foxit PDF Editor and Foxit PDF Reader (v 11.x, that is, the latest version of each); correspondingly, there are two such processes running on my system: FoxitPDFReaderUpdateService and FoxitPDFEditorUpdateService.
    (2) I did not configure the software with Foxit Admin Console. I just downloaded the software packages and installed them “as is”.
    (3) I was not doing anything special. First, I used FoxitPDFEditor to work on some PDF files. Then I de-installted both Foxit PDF Reader and Foxit PDF Editor and “killed” the two processes FoxitPDFReaderUpdateService and FoxitPDFEditorUpdateService. All of that had no effect. The CPU intensive *UpdaterService processes always reappear immediately after having been killed.

    Leave a comment:


  • Doris Wang
    replied
    Hi Axel Buchner,

    Sorry for the trouble. Could you help to confirm below information?
    1 The version number of the software (I guess it's Foxit PDF Reader?) you've installed
    2 Do you configure the software with Foxit Admin Console
    3 What were you doing when you noticed high CPU usage?
    Last edited by Doris Wang; 05-28-2021, 11:39 AM.

    Leave a comment:

Working...
X