No announcement yet.

Can not update Foxit - either no permissions or Foxit still open (not the case)

  • Time
  • Show
Clear All
new posts

  • Can not update Foxit - either no permissions or Foxit still open (not the case)

    This is annoying me. It's occurred previously with Foxit. Foxit tells me there is an update available. Clicking the buttons to update accordingly nothing happens or then tells me in order to update close Foxit.

    Going by another support ticket a got a while ago it was suggested to run the update program directly from the C: drive and 'run as administrator'. I tried that this time, the download appeared to work (where the hell does it download to?) and then when it was attempting to install and again, I was told to close down Foxit program. It wasn't even open.

    I went to task manager, made sure Foxit wasn't runing and then tried the direct update from the C drive, only for it to start downloading. Where is the file it downloaded earlier?

    How do I get updates without all this fluffing around?


  • #2
    Hi essaytee,

    Normally you may check for the update by going under "Help"->"Check for Updates" then install the update. If you fail to update from within the program, you may uninstall your existing version from "Control Panel"->"Add/Remove Programs" then download a new setup package from Foxit website and install the new version.


    • #3
      Thanks Cherry, I may have to do this (uninstall and then re-install) but surely that's a bandaid fix as for future updates I'll come across this same problem.

      I am the administrator of my Windows 7 Pro user account. I click the buttons to allow programs to make changes to my system. I'd like to know if the problem is at my end or not.



      • #4
        Thanks essaytee,

        I've also forwarded your comment as feedback for testing references. Thank you.