No announcement yet.

v6 change language

  • Filter
  • Time
  • Show
Clear All
new posts

  • v6 change language

    I am testing how to deploy foxit reader in my organisation. We are a multilingual company, so I want to make use of the extra language possibilities.
    So the idea was to install foxit reader 6, then create a lang subfolder and subfolders for a number of languages with the xml language file in there.
    And then set the HKCU\software\foxit software\foxit reader 6.0\preferences\langid to the language id I want.
    So for Dutch, I put this file "lang\nl-nl\mts_lang_nl_nl.xml"
    Then I set "HKCU\software\foxit software\foxit reader 6.0\preferences\langid" to "49010d"
    and "HKCU\software\foxit software\foxit reader 6.0\preferences\nChooseLan" to "1"
    If I open foxit, it just reverts everything to English.

    So how can I change the language at installation time ?

    I also noticed that a normal non-administrator user is not even able to change the language anymore:
    If I do the change within the foxit UI, it requires me to enter administrative credentials to do the change, eventhough the necessary language files in the program files folder are already present.
    Apparently it creates an updater process, which needs to alter something in the system?
    When a change to the default English is done, no administrative credentials are necessary.

  • #2
    Hi Peter74,

    Please make sure that it is lang\nl_nl\mts_lang_nl_nl.xml, it is a '_' rather than '-'. In registry editor, the langid for dutch should be 49110d and nChooseLan should be 1.

    The change of user interface requires administrator previledge. If you want to a quick update about this case, you may email to [email protected], attension: Cherry. Thank you in advance.


    • #3
      Yes of course it is an underscore. That must have been a typo when I put it in this post.
      Still, changing the registry value always reverts me back to the default (english) when I open foxit.

      That sounds like you're just acknowledging that it indeed requires admin rights for such a simple change. Something like "it's not a bug, it's a feature" ?

      Anyway, I just downloaded that new multilingual version, and that already solves a few things (French&German). But since Dutch is not included, I still have a problem with changing to that language.
      Our policy disallows giving admin rights to users.
      And the registry setting (langid) does seem to work to switch between built-in languages, but not to community translations, even when that language was chosen before and the language file is at the correct location.



      • #4
        Hi Peter,

        I've forwarded your comments to Reader PM team for processing. Feedback ID#: PMWQ-495. Thank you.


        • #5

          Foxit Reader 7.2.5 ML has already included 44 kinds of languages. They are German, French, English, Spanish, Italian, Dutch, Portuguese, Russian, Polish, Japanese, Korean, Simplified Chinese, Traditional Chinese for HK and Traditional Chinese for TW. You may give it a try at your convenience.