Announcement

Collapse
No announcement yet.

Security warning "opened by app without a valid signature" is shown again and again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Security warning "opened by app without a valid signature" is shown again and again

    Dear FoxitReader support team,

    When I launch PDF from Far Manager, FoxitReader v8.2.0.2051 shows the following message:

    Click image for larger version

Name:	FoxitReader_app.png
Views:	2887
Size:	14.7 KB
ID:	166134

    I check the checkbox "Remember your choice" and click "OK". However when I launch another PDF, the same warning is shown again. Also when I modify PDF, it is shown again.

    Can this confirmation be remembered once and forever?

  • #2
    Dear dma_k,This issue you mentioned should have already been fixed in our latest version of Foxit Reader 9.0.1.
    Please help to upgrade your Foxit Reader to latest version 9.0.1 by downloading it from our official download center below:
    https://www.foxitsoftware.com/downloads/

    Comment


    • #3
      I have this problem when I open a PDF from Launchy. I check the "remember" box but it does not remember. I have the latest version of Foxit Reader 9.0.1, which I just downloaded today.

      Comment


      • #4
        Dear Mark Rook,

        Sorry for the trouble our software causes to you.As to this issue you mentioned,we need your help to send us the following information for further analysis:
        1:Your OS information(eg:mine is windows10x64 bit).
        2: Did you download Launchy from this website:
        https://launchy.en.softonic.com/
        3:When the security warning message appear again,please check the "remeber"again and navigate to the following folder to find the
        "TrustApp.xml" file for us:
        "C:\Users\Public\Foxit Software\Foxit Reader"
        3:Please go to "Start"->"Run"-> input registry -> find "HKEY_CURRENT_USER\Software\Foxit Software\Foxit Reader 9.0" ,please right click on the "Foxit Reader 9.0" and select"Export"to export the Foxit Reader registry key file for us.

        Comment


        • #5
          I was facing the same problem FoxitReader v8.2.0.2051. I upgraded my version to Foxit Reader 9.0.1. However, I was facing the same problem again, so what I did, uninstall the software and again install the Foxit Reader 9.0.1. Now it is working properly.

          Comment


          • #6
            Dear Lisa,

            Sorry for the delayed response. I had stopped checking for an answer. In answer to your questions:

            1. Windows 10 64-bit
            2. I don't remember from where I downloaded Launchy - I've had it for years and it works well, so I'd rather not reinstall
            3. The C:\Users\Public\Foxit Software\Foxit PhantomPDF folder is empty, except for a sub-folder ("StartPage") - maybe this is the problem
            4. I've attached the registry download (I had to change the extension to .txt from .reg because the browser said I am not allowed to upload .reg files).

            I saw the kevinwalker above solved the problem by reinstalling. I'd rather not do that, because I spent a while setting all of my preferences and don't want to have to repeat this work.

            Mark
            Attached Files

            Comment


            • #7
              Mark Rook ,We have released a newer version 9.1 of Foxit Reader.Please help to install the latest version by clicking on the "Help"tab in Foxit Reade>"check for updates"to download and install V9.1 version there or download a ner installer from the link below:
              http://cdn09.foxitsoftware.com/produ...etup_Clean.exe
              If you choose not to remove all related registry and data during install update,then those Preferences settings that you made will still be retained in the newer version.
              Finally,please try to give the new installation a try and let us know the result.

              Comment


              • #8
                Thanks again, Lisa. I installed the newer version from the link you provided. Unfortunately, it still did not solve the problem. The C:\Users\Public\Foxit Software\Foxit PhantomPDF folder is still empty, except for a sub-folder ("StartPage").

                Mark

                Comment


                • #9
                  Mark Rook ,Dear Mark Rook,I am sorry that the location for finding "TrustApp.xml" that I have sent is for Foxit PhantomPDF application.
                  For Foxit Reader,you have to find the "TrustApp.xml" file under:
                  "C:\Users\Public\Foxit Software\Foxit Reader"
                  And please also help to go to "Help"tab in Foxit Reader>"Preferences">"Trust Manager",click on "Change settings..."button under the "Open Foxit Reader from applications without valid digital signatures"to open the"Trusted Apps..."to see if the "Launchy" is already listed in the Trusted apps?
                  If so,please help to manually input your "Launchy" applicatio location there.For example,I have "Launchy" installed under "C:\Program Files (x86)\Launchy" this folder,so I iniput
                  "C:\Program Files (x86)\Launchy\Launchy.exe"in the allowed apps field,click on "Allow"to add it,click on "OK""OK"to save the setting.
                  Then please close and reopen your Foxit Reader to open the "Preferences"dialog box to double check if the "Launchy" application has already been added in trusted apps successfully?
                  Attached Files

                  Comment


                  • #10
                    Now it works just fine! Thanks!

                    Comment


                    • #11
                      I found the solution to a similar problem opening a PDF from Chromium.

                      Giving the user permission to write a file in "C:\Users\Public\Foxit Software\Foxit Reader" made the "remember" work.

                      Thanks for giving me the right place to start looking

                      Comment


                      • #12
                        Hello All, To add applications without valid digital signatures as trusted applications in Foxit Software,please refer to instructions listed in the article below:
                        https://help.foxitsoftware.com/kb/ho...phantompdf.php
                        To disable the security warning when Foxit is launched by a third-party application without a valid digital signature,refer to the article below:
                        https://help.foxitsoftware.com/kb/ho...-signature.php

                        Comment


                        • #13
                          The problem with the initial report is that it offers the user "Remember the choice for this application" but the choice is not persisted. The issue is still there in v10.1.0.37527, namely, if "Remember the choice for this application" is checked, the choice is not remembered.

                          Comment


                          • #14
                            dma_k ,Thanks for your response. Regarding this issue ""Remember the choice for this application" is checked, the choice is not remembered",please help to provide with us the following information:
                            1:Your OS information(E.g.windows 10x64bit).
                            2:Please help to check the option "Allow multiple instances" under the "Documents" tab in Preferences is checked or not checked on your part?If it is checked,please choose to uncheck it and click on OK to save the setting,then please try to click on "Remember the choice for this application"button as usual when the warning message appears again to see if it helps?
                            3:Please give us the specific name of the application which doesn't have a valid digital signature and its installation location in your computer.
                            4:If it is possible,please help to use the licecap tool to generate an animated gif that shows your whole process:
                            http://sync-us.foxitsoftware.com/iss/Tools/LICEcap.zip
                            (Unzip it, then double-click on licecap file, you can then specify the recording area then hit "Record", it requires naming the file first then start recording.)

                            Look forward to your reply.

                            Comment

                            Working...
                            X