No announcement yet.

Some pdfs not opening by default with Foxit

  • Time
  • Show
Clear All
new posts

  • cena05
    Thanks for your help. I don't open with a browser. I just use the stand alone pdf viewer. I currently have pdf's hyperlinked into an access database and for some reason every couple of pdf's will open with adobe pdf viewer instead of the default foxit. I checked the box "Use Foxit Reader to open embedded Acrobat files in Microsoft Office" in the File Association settings. Hopefully this will fix it. Thanks again for your help.

    Leave a comment:

  • redwolfe98s
    you should give more information, like explaining which other programs are opening PDF files.. the problem could be due to the way that you installed the foxit PDF reader program.. if you used the option for installing the IE plugin, so that PDF files would open in IE, that probably explains why PDF files are opening in IE..

    the firefox browser is able to open PDF files.. in firefox's settings for "applications", if you have FF set to open PDF files, that explains why firefox is opening PDF files..

    some people like having PDF files open in their browsers.. some people don't..

    as for myself, when i am installing the foxit PDF reader program, i don't install any extras..i only install the foxit PDF plugins (for opening PDF files in IE) shell extensions..

    i also disable firefox's ability to open PDF files, and, in FF's settings for "applications", for PDF files (application/PDF), i have it set to "always ask", so that firefox always asks me if i want to save the PDF file or open it with the foxit PDF reader.. (sometimes i save a PDF file; sometimes i go ahead and open them in the foxit PDF reader)..

    since i don't install the IE plugin, PDF files are not opened in IE (i rarely use IE).. since i disable firefox's ability to open PDF files, as well having firefox set to "always ask" me what to do with PDF files, PDF files are not opened in firefox..

    it might not be necessary to disable firefox's ability to open PDF files..maybe having firefox's settings for "applications" set to "always ask" what to do with PDF files is all that is needed, but, since i don't want firefox to open PDF files, i disable its ability to open them by tweaking firefox's settings.

    to disable firefox's ability to open PDF files, type "about:config" in firefox's "location bar" (address bar) and press "enter", to open FF's "configuration".. then, in FF's "configuration", scroll down to "pdfjs.disabled" and change the setting from "false" to "true" do that, just click on "pdfjs.disabled" to toggle the setting, switching it from "false" to "true"..

    don't forget to also change firefox's settings for "applications", setting "application/PDF" to "always ask" (or "always open with foxit PDF reader")..

    if you need to remove the foxit plugin for IE, you can figure out for yourself how to remove the plugin, either by just looking in IE's settings, or by using google-search to pull up information about how to do that..

    if you use the "chrome" browser and there is a chrome-plugin that is opening PDF files in the chrome browser, you can look for information about how to disable that..

    in the foxit PDF reader's settings, in the settings for "file associations", you should have it set so that foxit is the default PDF reader and so that it always checks to make sure that it is the default PDF reader.. however, i don't have "include browser", "include preview", or "include thumbnails" ticked, for "file associations"..

    also, in foxit's settings, for "page display", for "navigation tab", you should have it set to "pages only".. in the "general" settings, for "application startup", you should untick "show start page" and "show advertisement".. in the settings for "trust manager", i would recommend disabling javascript, which makes viewing PDF files much safer, as far as malware in concerned..

    i also disable the foxit program's automatic updating, but that is up to you..

    Leave a comment:

  • cena05
    started a topic Some pdfs not opening by default with Foxit

    Some pdfs not opening by default with Foxit

    I have set Foxit as my default pdf viewer, but some pdfs still open with other applications. Has anyone else had this problem?