Announcement

Collapse
No announcement yet.

Foxit Reader freezes few seconds on start

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi Richell_huang.

    I realize this may be a bit of a Necro post. But I just came across this exact situation myself. Renaming the FoxitDrive.fpi file was the fix.
    It's also worth mentioning that this problem only occurs when I am connected to my VPN. I suspect it's trying and failing to connect to some service using my standard gateway and having the traffic re-routed/blocked.

    I am currently running 9.4.0.16811

    Comment


    • #17
      Nestar

      Thank you for your feedback, it has been updated to our team for further investigation, any updates, I will keep you informed.

      In addition, would you please help to update to version9.5 as the following way to see if it helps?

      1) Uninstall Reader from the control panel.
      2) Press "Window + r" input "regedit" press Enter, find folder "Foxit Reader" under the directory "HKEY_CURRENT_USER\Software\Foxit Software\Foxit Reader" and delete it.
      3) Go to the installation folder of Foxit Reader, somewhere like:C:\Program Files\Foxit Software, delete the folder"Foxit Reader"
      4) Download it from the following link and run it as Admin to install the program.
      http://cdn01.foxitsoftware.com/produ...etup_Clean.exe

      If you still get the issue, please open Foxit, go to File>Preferences>General, check the option"Lauch in debug mode" under Application Startup.Restart Foxit, and try to reproduce the issue.
      Then go to C:\users\Your Name\AppData\Local\Foxit PhantomPDF\glog , send us the whole folder "glog" , thanks in advance.

      Comment


      • #18
        Alright, I've done that.

        Unfortunately it doesn't look like debug is recording the necessary information.

        Here's the log created from a launch without the freeze (No VPN running)

        Log file created at: 2019/06/06 08:35:43
        Running on machine: DESKTOP-FRGMJJE
        AppName: Foxit Reader
        Version: 9.5.0.20723
        Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line function] msg
        I 0606 08:35:43.173233 35724 foxitreader.cpp:2301 CFoxitReaderApp::InitInstance] Test CFoxitReaderApp::InitInstance start
        I 0606 08:35:43.820225 7636 foxitreader.cpp:628 CFoxitReaderApp::VerifySignatureThread] CFoxitReaderApp::VerifySignatureThread---start

        and another with the freeze

        Log file created at: 2019/06/06 08:36:43
        Running on machine: DESKTOP-FRGMJJE
        AppName: Foxit Reader
        Version: 9.5.0.20723
        Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line function] msg
        I 0606 08:36:43.297091 30024 foxitreader.cpp:2301 CFoxitReaderApp::InitInstance] Test CFoxitReaderApp::InitInstance start
        I 0606 08:36:54.951947 22928 foxitreader.cpp:628 CFoxitReaderApp::VerifySignatureThread] CFoxitReaderApp::VerifySignatureThread---start


        Also, for what it's worth, the glog location is "%AppData%\Local\Foxit Reader\glog"
        PhantomPDF is in
        "%AppData%\Roaming\Foxit Software\Foxit PhantomPDF" and only contains a spellcheck folder
        Last edited by Nestar; 06-06-2019, 01:45 PM.

        Comment


        • #19
          Nestar

          I've updated your comments to Foxit internal bug tracking system as Report ID#: QCPHANTOM-18472 for further processing. We'll keep you posted with the update. Thank you.

          Comment


          • #20
            Sounds good, thanks.

            If you get another build that will give more debug info that you'd like me to test let me know. I'll try to keep an eye on this thread. For now the fix of renaming that file is working just fine for my usage.

            Comment


            • #21
              Nestar ,we will update any new progress about this issue in this thread on our forum for you.

              Comment


              • #22
                Nestar

                Please help to generate the log files as the following way for further troubleshooting.
                1. Go to the installation folder of Foxit Reader, navigate to C:\Program Files (x86)\Foxit Software\Foxit Reader, new a Text Document and rename it to EnableLogging without the extension'.txt'.
                2. Enable FoxitDrive plugin, try to reproduce the issue;
                3. After reproduce the issue, please go to C:\Users\your user name \AppData\Roaming\Foxit Software\Foxit PhantomPDF\log , send us all files in the log folder.
                4. Disable FoxitDriveplugin, try to reproduce the issue;
                5. After reproduce the issue, please go to C:\Users\your user name \AppData\Roaming\Foxit Software\Foxit PhantomPDF\log , send us all files in the log folder.

                Thank you.

                Comment


                • #23
                  Here's the content of those logs when the delay occurs. (pasted one after the other with the filename between each section)

                  https://pastebin.com/NQGAFi3e

                  Note that it is again, %appdata%\Roaming\Foxit Software\Foxit Reader\Log
                  and not PhantomPDF

                  I'm unable to reproduce the issue with drive plugin disabled (renamed)

                  Here's another log without the delay (with my VPN turned off), for comparison purposes.

                  https://pastebin.com/vzyJtQxJ
                  Last edited by Nestar; 06-12-2019, 05:50 PM.

                  Comment


                  • #24
                    Nestar

                    Thank you for your info, it has been updated to our team for further investigation, any updates, we will keep you informed.

                    Comment

                    Working...
                    X