Announcement

Collapse
No announcement yet.

scrolling bug since last update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • scrolling bug since last update

    This wasn't happening even just very recently. So I assume 9.4.0 caused it.
    When I try to scroll using middle click and dragging, it scrolls at a super slow speed. And when I use page up or down, it makes it auto scroll also at the slow speed.

  • #2
    yonabe

    You can use the Up/Down arrow keys on your keyboard to change the scrolling speed.



    Comment


    • #3
      So, it's a recent intentional behavior? Really bizarre, but your tip works, so I can live with it and hope it gets fixed. But also, when I press up/down/pageup/pagedown (and maybe other keys) when I'm not scrolling, autoscroll just triggers. Is there a way to keep that off?

      Comment


      • #4
        Actually, it's not just the navigational keys, ctrl/shift/a random alphabet, just any key can trigger the autoscroll.
        Clearly something about autoscroll is broken, or it's just me.

        Comment


        • #5
          I can confirm the issue, and simply changing the scrolling speed doesn't work. The problem, more specifically, is that:

          1. Middle click and dragging used to have its own scrolling behavior: the farther you drag the mouse, the faster the scroll is. Which was consistent to how it behaves in most other applications. With 9.4 (can confirm that this issue appeared in the new update) middle click now activates auto scrolling at constant speed and dragging the mouse pointer only changes the scroll direction.
          2. This means that I cannot quickly and precisely adjust my scroll speed by moving the mouse when dragging. I need to constantly use the keyboard to change the speed one small step at a time. This feels very annoying and inconvenient. Also:
          2.1 Every time I launch Foxit Reader, the scrolling speed is set to super-slow again.
          2.2 Current max scrolling speed is way lower than I could achieve with "middle click and drag" method.
          3. As Yonabe pointed out, using Page Up / Page Down after auto scrolling sometimes enables auto scroll again, which looks like a bug.

          I really hope that this is just a bug. Even if it is not, I suggest reverting the middle click behavior to pre-9.4 version, please.There is no need to tie this distinct scrolling method to the default autoscroll behavior and it really affects the usability.

          Comment


          • #6
            Verence

            I could also reproduce the mentioned changing the scrolling speed via middle click and drag in 9.4.0 didn't work issue and have escalated the issue to Foxit internal bug tracking system for QA and Dev engineer's further investigation. Report ID#: QCPHANTOM-14771.

            Regarding "using Page Up / Page Down after auto scrolling sometimes enables auto scroll again", I think it is normal, when you click the middle button of mouse, then drag the mouse then the Autoscroll is enabled; if you simply click on the middle button of the mouse without dragging the mouse, then you press Up/Down arrow key to adjust the speed, the AutoScroll will not be enabled.

            Thank you.

            Comment


            • #7
              cherry

              Thanks for the response. However, regarding the last issue, I was speaking about a slightly different problem. The steps to reproduce are:

              Click the middle mouse button to enable autoscroll. Drag the mouse around to scroll a bit, then click the MMB or LMB to disable autoscroll. Then press Page Up (not Up arrow) / Page Down / any alphanumeric key. The autoscroll suddenly turns itself back on.

              Comment


              • #8
                Verence

                Thanks for the detailed update and I could reproduce this issue as well. I've reported it to Foxit internal bug tracking system as well "
                QCPHANTOM-14771: Page Up /Page Down/any alphanumeric key after auto scrolling sometimes enables autoscroll again". I'll keep the status posted here or you email to support@foxitsoftware.com with this ID# to track the processing status as well. Thank you again.

                Comment


                • #9
                  I hope we see a fix very soon.

                  This has caused a sore point with my daily workflow. I'm just glad to discover it's Foxit and not a Win10 problem. Before discovering this thread I had entered a "suggestion" in the online forms (FOXIT #249769). Please consider that suggestion as a confirmation of this bug.

                  Thank you.

                  Comment


                  • #10
                    Originally posted by TimberWolf View Post
                    I hope we see a fix very soon.

                    This has caused a sore point with my daily workflow. I'm just glad to discover it's Foxit and not a Win10 problem. Before discovering this thread I had entered a "suggestion" in the online forms (FOXIT #249769). Please consider that suggestion as a confirmation of this bug.

                    Thank you.
                    Yes, we have reported it as bug and our development team are working on the issue. We will keep you informed when the issue is fixed.

                    Comment


                    • #11
                      Whats the status of this Bug?
                      Its really annoying experience.

                      I currently using foxit reader Version: 9.4.1.16828, but it is buggy in last version i installed too.

                      Last edited by mahpooya; 02-13-2019, 06:33 PM. Reason: adding data

                      Comment


                      • #12
                        Originally posted by mahpooya View Post
                        Whats the status of this Bug?
                        Its really annoying experience.

                        I currently using foxit reader Version: 9.4.1.16828, but it is buggy in last version i installed too.
                        Sorry that it has not been addressed yet, we have sent a reminder to urge it, hope it will be fixed as soon as possible. Any update, I will keep you posted, thank you.

                        Comment


                        • #13
                          My user's are also complaining about the new scrolling method, really would prefer to go back to the mouse controlling the scroll speed after middle click, just like every other application out there!

                          Comment


                          • #14
                            Originally posted by j2mc View Post
                            My user's are also complaining about the new scrolling method, really would prefer to go back to the mouse controlling the scroll speed after middle click, just like every other application out there!
                            j2mc ,Before the problem gets addressed ,we suggest you downgrade to V9.3 for getting around this situation you referred. Hereby links to download V9.3 of Foxit PhantomPDF and Foxit Reader:
                            http://cdn09.foxitsoftware.com/product/phantomPDF/desktop/win/9.3/FoxitPhantomPDF93_enu_Setup.msi
                            http://cdn09.foxitsoftware.com/product/reader/desktop/win/9.3/FoxitReader93_enu_Setup_Clean.exe

                            Comment


                            • #15
                              4 months since the initial post and still no resolution except to downgrade (from an upgrade that was purchased).

                              Just how complex is this problem or are there other more pressing matters taking priority at foxit?

                              Disappointed in a product I've used and recommended for years.

                              Comment

                              Working...
                              X