Announcement

Collapse
No announcement yet.

Unable to update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cherry
    replied
    Hi Sherry,

    Please try to do the update manually for now (uninstall your existing version from Control Panel then download a new installer to install). I'll forward this problem to Reader QA team for further investigation. Thank you.

    Leave a comment:


  • sherry
    started a topic Unable to update

    Unable to update

    I am using Foxit Reader version 6.0.6.0722. For several days, I have been trying to update to version 6.1.2.1224. When I click on "check for updates" I get the message "Unable to connect to the network or System is busy. Please try again later." I have tried a dozen or so times over several days and always with the same result. Can someone tell me what could be wrong.

    Thank you.
Working...
X