Announcement

Collapse
No announcement yet.

Disable links pointing to a different location within the same PDF document

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lisa_lee
    replied
    Novgorod ,we would like to know that which version of Adobe acrobat do you use? I have tested in Adobe Acrobat pro DC on my part and I noticed that it handles the issue in the same way with Foxit PhantomPDF now.When I left clicked and held on the link location ,then moved my mouse,nothing happened on my part before I released the left mouse button.
    Would you please help to send us one PDF file in question and also use the licecap tool to generate an animated gif that shows your whole process in Adobe acrobat:
    http://sync-us.foxitsoftware.com/iss/Tools/LICEcap.zip
    (Unzip it, then double-click on licecap file, you can then specify the recording area then hit "Record", it requires naming the file first then start recording.)
    If it is not convenience to send documents on forums,please help to email them to [email protected] (Attn.Lisa) and indicate this thread link when you mail to us.



    Leave a comment:


  • Novgorod
    replied
    Ok, thanks.
    By the way, Adobe's Acrobat handles this issue in a smart way, which you may also implement in the future ... It recognizes links when using the hand tool (hand icon has a little arrow on it) but it only follows the link if you click on it without moving. When you drag (click, hold, move), it always ignores the link and just drags the document as intended. This seems the best way to me and doesn't require any additional options.

    Leave a comment:


  • lyndi_wu
    replied
    Novgorod

    The Flatten issue only exists in Foxit PhantomPDF, if you are using Foxit Reader, you can try the below to see if it helps.
    1. Open Foxit Reader, go to File>Preferences>Print, check the option"Print text as a graphic...", click on OK.
    2. Open your file, and print it with Foxit Reader printer to create a new pdf file.

    Leave a comment:


  • Novgorod
    replied
    Thanks! It would be great to have the option in the future. The "flatten" feature seems not to be a part of Foxit Reader, so I assume you're referring to the editor (PhantomPDF), right?

    Leave a comment:


  • Lisa_lee
    replied
    Novgorod ,For this situation you mentioned,we have submitted the suggestion"Support to remove links that point to a different location within the same PDF document or add an option '"automatically follow links with the hand tool" " as a new feature request with suggestion ID#PHANTOM-14275,so that it may be considered in future versions.

    For your current workaround,we suggest you choose to use the "Flatten"feature under the "Organize" tab to merge those link annotations into file's content layer which will remove all of those links you mentioned,then you will be able to use the hand tool to drag the document again.

    Leave a comment:


  • Novgorod
    replied
    Yes, the links are only activated by the hand tool, but this means that the hand tool is not usable if the whole document is covered in links. This is a problem because dragging the document with the hand tool is the most important convenience feature when viewing PDFs. I understand that this problem is not of highest priority but it would be nice to add an option like "automatically follow links with the hand tool" (enabled by default) and if it's disabled, the hand tool is locked to dragging only.

    Leave a comment:


  • lyndi_wu
    replied
    Novgorod

    Sorry, now Foxit does not have an option to disable internal (or all) hyperlinks either for the current document or in general, but may I suggest you to select the tool Home>Select>Select Text and Image when you open this pdf file? Then the links will not be enabled, because links can be activated only with Hand tool.



    Leave a comment:


  • Disable links pointing to a different location within the same PDF document

    By default, Foxit Reader lets you click on hyperlinks within a PDF document when using the hand tool. This applies not only to external (web) links, but also to internal links pointing to other pages/sections within the document. This is generally useful (e.g. jump to figures or references within the document linked in the text), however I encountered some documents "abusing" the internal linking function by making the entire text section a giant link pointing to the next page or paragraph. I don't know the purpose of this (maybe for people who don't have a mouse wheel to scroll), but it makes the hand tool unusable for dragging since anywhere you click is a link (the hand tool icon has a downward pointing arrow on it).

    It's certainly possible to remove these links by rebuilding such documents with a PDF printer/creator, but it would be much more convenient if Foxit Reader had an option to disable internal (or all) hyperlinks either for the current document or in general. Is there such an option?
Working...
X