Announcement

Collapse
No announcement yet.

Lock Horizontal Scrolling when viewing pages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feature Lock Horizontal Scrolling when viewing pages

    Hi,

    I love Foxit reader, but there's something bugging me.

    How can I turn off the horizontal scroll when viewing pages, or doing a search?

    Alternatively, is there a way to center the page in the viewing area?

    When searching through the documents, the pages move to center the searched words. Can I lock the horizontal scroll, or otherwise stop the pages from moving?

    Thank you.

  • #2
    Sorry that I am not quite understanding it. When viewing pdf pages, if the Horizontal Scrolling is locked, then how to scroll the pages when viewing pages? We appreciate if you can describe your request in detail or use licecap to generate an animated gif that shows it for our referencing.
    Here's the download link:
    http://sync-cn.foxitsoftware.com/iss/Tools/LICEcap.zip
    (Unzip it, double-click on licecap file, you can then specify the recording area then hit "Record", it requires naming the file first then start recording.)

    Comment


    • #3
      Hi Richell,

      Thanks for following up on this.

      Maybe a better question would be how does the horizontal scroll bar triggers, as I have documents that has not filled the viewing area, but has the horizontal scroll. Is this due to the way the document is set up? I noticed when viewing the foxit manual, the horizontal scroll does not appear until the zoom overfills the viewing area. For me when I am viewing this document, and searching for words, it makes the alignment of the document move right/left as it shows the search results.

      Thank you.
      Click image for larger version

Name:	Foxit Horizontal Scroll Bar.jpg
Views:	392
Size:	92.3 KB
ID:	177993

      Comment


      • #4
        Botzilla78 Please kindly note that the horizontal scroll bar will show when the zoom in value larger than 200. For Foxit User Manual, it has set default layout so that the horizontal scroll does not appear until the zoom overfills the viewing area.
        Currently, there is a rule about PDF's layout in Foxit as below, can you please check them and have a try? thanks
        There are four factors affecting the page layout display:
        1) "Restore last view settings when reopening" option;
        2) Initial View;
        3) "Default Page Layout" option under "Preferences".;
        4) option "Override Page Display" under Accessibility
        The display priority order is 4>1>2>3.

        1) If the PDF document been opened before and the "Restore last view settings when reopening" is checked under "Preferences" , Reader will read the "Page layout" and "Magnification" setting opened last time and display accordingly.
        2) If the PDF document never been opened before, Reader/Phantom will check if there's "Initial View" setting of the PDF document:
        a. If there is initial view setting, Reader will read the Page Layout and Magnification setting in initial view setting then display;
        b. If there isn't initial view setting, Reader will read the Page Layout and zoom setting in "Preferences>page display>Navigation tab".
        So in this case, if there isn't initial view setting, please run Foxit Reader and go to File->Preferences->Page display to select 'facing' as the default page layout, then go to File->Preferences->History to uncheck "Restore last view settings when reopening" option, it should work as you desired.
        3) Since version 9.0, we've added an option "Override Page Display" under "File">"Preferences">"Accessibility">"Override Page Display" so we could force page layout/zoom level as desired.

        Comment

        Working...
        X