No announcement yet.

Default printer issuein RDP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Default printer issuein RDP

    In our 2016 RDP environment, Foxit Reader keeps taking over as the default printer, for a user, in Excel. When this happens another printer cannot be chosen. The oddest part, is this is only happening with one user in the RDP farm. We have tried making sure the correct printer is set to the default for her, and Foxit still takes over. Additionally, we have tried completely re-creating her profile in RDP. Any ideas about this issues would be appreciated. Thanks

  • #2

    Sorry for the trouble. Would you please help provide us with the following info further investigation?
    1.The version of Foxit Reader you use.
    2. Does the issue just happen to Excel? How about other programs, like Notepad?
    3. Does it happen to any Excel files? If it happens to a specific file, please send us the sample for internal test.
    4. The version of Excel you use.
    5. Would you please delete Foxit printer from printer paneltemporarily, then I send you the installation file of Foxit Reader printer and install again to see if it helps?



    • #3
      Hi Lyndi,

      1. We are using version in our RDP environment
      2. The issue has only been reported with Excel
      3. It appears to happen to any Excel files. Although, I will contact my users, as there are 2 reporting it now, to see if they have issues with all, or specific, files
      4. We are using Office 2016 in our 2016 RDP environment. Due to some issues with OneDrive in RDP, we are not using O365 there yet
      5. I will see about getting the Foxit printer removed from the users' profiles

      Once I hear back from my users, I will post another reply. Thank you for your assistance.


      • #4
        OK. So, here is what I have tried:

        I accessed RDP and created a new Excel file and placed it where the users could access it. They still cannot change from the Foxit Printer. Additionally, I tried printing, and receive the same issue. When printing, the Foxit Printer comes up, even though I have something else as a default. I then choose the desired printer and Foxit pops back in. I then logged in as Local Admin and removed the Foxit printer from the server. I re-opened the newly created file, and now the Adobe PDF printer does the same thing the Foxit printer was doing.

        Additionally, I tried some of the other possible printer options. I am able to choose any printer that is not a physical printer, like Microsoft's XPA Document Writer, Microsoft PDF priner, OneNote printer, etc. I am investigating further now.


        • #5
          pattere ,You mentioned that the adobe PDF printer does the same thing the Foxit printer was doing after you having removed Foxit Printer. From this situation, we could tell that the problem is not related to PDF printer itself,it may have something to do with the user's profile and RDP environment.


          • #6
            Not sure what part of the profile to check, as I can now duplicate the issue with my login, whereas I couldn't previously. It's like Excel doesn't "see" the physical printer(s) when they are chosen from the drop down.

            I did find that if I removed, re-added, and re-set the physical printer to default, I was able to have it populate in Excel. However, following the weekend RDP server reboots, it reverted back to the Adobe printer and not being able to choose the physical printer.


            • #7

              According to your description, the issue seemed to happen with Adobe printer as well. So I would encourage you to contact Microsoft support as well and see if they could shed any light on this issue. Thank you.