No announcement yet.

Foxit Reader always starts slow first time

  • Filter
  • Time
  • Show
Clear All
new posts

  • Foxit Reader always starts slow first time

    I'm new here and I'm writing from Germany. I actually use Foxit Reader ( on serveral different PCs each with Windows 10, also Microsoft Surface Go 128 GB/8 GB Ram. I use Foxit Reader already many years, but last time no matter on which PC Foxit Readers always starts very slow for first time. It takes arround 10 sec. until the pdf document is readable. Acrobat Reader is starting much faster, within 1-2 sec.! Why Foxit Reader starts so slow? Is there any option I can acitivate for faster start? Any ideas?

    Many thanks for your help and Merry Christmas to you all !

    Wuffi from Germany

  • #2
    Could you please go to File->Preferences->General->check 'Disable all features which require internet connection' option to see if it helps? Thank you.


    • #3
      Thanks, I have checked, it was disable. I have activate now and restarted the PC, but not really faster , maybe little faster

      Click image for larger version

Name:	Image 1.jpg
Views:	15
Size:	124.7 KB
ID:	180950


      • #4
        Wuffi Sorry for the problem you encountered with Foxit reader. Could you please kindly perform a fresh re-installation as following and try again´╝č
        1) Please make sure you've closed all Foxit reader related programs (IE, Firefox...) then go to "Control Panel"->"Add/Remove Programs" to uninstall Foxit reader;
        Go to "Start"->"Run"-> input regedit -> find "HKEY_LOCAL_MACHINE\SOFTWARE\Foxit Software\ Foxit reader 10.0" and "HKEY_CURRENT_USER\Software\Foxit Software\ Foxit reader 10.0" to delete the whole folder of Foxit reader 10.0;
        2) Install the latest version 10.1.1 of Foxit reader. Please download the installer from the link below:
        Finally, please give the new installation a try and let us know the result. Thanks