Announcement

Collapse
No announcement yet.

Foxit Reader for MacOS: The certificate has exceeded the time of validity

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Foxit Reader for MacOS: The certificate has exceeded the time of validity

    On Foxit Reader for MacOS (Version 3.3.0.0709), I am applying a Self-Signed and Trusted certificate created in Certificate Assistant (created in MacOS BigSur 11.5) and valid for expiration until one year from today. When I try to apply it to a PDF in a form field for signature, I get a popup that states: "The certificate has exceeded the time fo validity" What does this mean? In the "Select Certificate" window it shows my certificate as valid for a year from today. Is this an issue with my certificate or some kind of bug with signature processing in Foxit Reader?

  • #2
    micahgardner

    Sorry for the trouble. The version you are using the oldest version, would you please help upgrade Foxit Reader for Mac to version 11 to see if it helps?

    You can download the latest version from our website.
    https://www.foxit.com/downloads/#Foxit-Reader/

    Thanks,

    Comment


    • #3
      I have the same issue on 11.0.1.0719. Is a fix scheduled?

      Comment


      • #4
        Elliott Barrere micahgardner We apologize for any difficulty using Foxit Software, it's a known issue and our team is working on that issue as report id#MACLNX-10245, will fix it soon in the future.
        Here is a workaround you check it out:
        Set the system time to yesterday or the day before yesterday, then create a new certificate, and then restore the system time, the certificate can be used normally.

        Comment


        • #5
          Sounds like a similar problem to the one I have. I use Multi-Commander (64) on Windows. every time I open a pdf Foxit throws up an error window. There is an option to check a box allowing Foxit to remember my choice to open files in Multi-Commander. It has never worked. I am going to switch to another pdf reader. When you come up with a fix or when anyone can tell me how to force Foxit to remember Multi-Commander, let me know. Foxit is otherwise easy to use.

          Comment


          • #6
            Grace O

            Sorry for the trouble. Actually this topic is for Foxit Reader MacOS on creating/placing the signature, it seems that you have a different problem that you will get security warning as the attached screenshot when open a pdf file from Multi-Commander (64)? Right?

            If yes, would you please click the check box “Remember your choice for this application” and click on OK to close and avoid this warning message.

            https://kb.foxitsoftware.com/hc/en-u...arning-Message
            Attached Files
            Last edited by lyndi_wu; 11-03-2021, 02:11 AM.

            Comment


            • #7
              I wish it was that simple. No matter how often I check the box (which is quite visible) nothing changes. It doesn't matter if it is different pdf files or the same one in a different session. The check box is useless. I have tried rebooting the computer in combinations with and without re-installing the software for Foxit reader (WIN) with and without re-installing Multi-Commander, makes no difference.
              I have wasted the better part of the day trying everything I know -- and still get the warning message every time I try to open any pdf file.

              Foxit recently stopped printing anything. The "print" command is ghosted and the batch print also is ghosted. I am ready to find something that I can rely on when I need it. I don't have any more days to spend trying to get my work printed.
              It's too bad, Fox it has worked beautifully until about 5 months ago. I've recommended it to other people. 5 months limping with a broken program is enough.

              Is Foxit only supporting WIN 10+ now?

              Comment


              • #8
                Grace O

                Sorry again for the inconvenience the issue caused.
                Regarding the issue "security warning: Checking the box "Remember your choice.." does not add the application as the allowed app": Since the TrustApp.xml is stored in "C:\Users\Public\Foxit Software\Foxit PDF Reader", the system requires to have admin rights to write into the TrustApp.xml. Could you please help check if the current user you logged in as has the write access to the C:\Users\Public? See attached.

                Regarding "Foxit recently stopped printing anything": Was there any error you got when you try to print? What is your setting in "Print What" section in the print dialog?
                Attached Files
                Last edited by cherry; 12-01-2021, 02:06 AM.

                Comment


                • #9
                  Thanks, I am the administrator. I am the only one who uses this computer. It's not on a work network or a home network. The "print" command on the left side of the screen (menu item) is ghosted. A couple of other items are also ghosted.

                  I will check to see the folder you pointed to see what is shown in it.

                  Comment


                  • #10
                    Grace O ,Thanks for your response. Did you already check the permission on your account for accessing "C:\Users\Public“?If the issue still happens after you have assigned accessing permission to your account ,please help to provide with us the following information for further analysis:
                    1:Your OS information (E.g.windows 10x64bit).
                    2:Click on 'Help"tab>"About Foxit PDF Reader" to check its version number.
                    3:A screenshot of the warning message.
                    4:When the warning message pop up again,please make sure to check "remember your choice for this application" and hit "OK".

                    and then go to File tab in Foxit PDF Reader,click Preferences,click Trust Manager tab,click on option Change settings… which is under Open Foxit PDF Reader from applications without valid digital signatures part to bring up Trusted Apps… dialog,please help to check the Apps section in the "Trusted Apps..." dialog box to see if the third party application in which you tried to open PDF file there was already listed there? Then please take a screenshot of the pop-up trusted apps dialog box that you could see on your part.
                    5:If the third party application is still not listed under the "Apps" section, please help to manually input the full directory of the thrid party application(For example: C:\ROPro210\output\ROPro2.exe ) into the allowed apps click on "Allow" to add it ,click on "OK""OK" to save the setting.

                    Then open reopen the preferences dialog box again to check if the third party application directory was already listed under the Apps section?
                    6:If you could manually add the third party application directory under trusted apps list in the preferences dialog box successfully,then please try to restart your Foxit PDF Reader to open PDF file from third party application again to see if this will suppress the warning message?

                    Look forward to your reply.

                    Comment

                    Working...
                    X