Announcement

Collapse
No announcement yet.

Opening a PDF/A file in PDF/A mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Opening a PDF/A file in PDF/A mode

    By default, Foxit PDF Reader should open PDF/A-compliant documents in PDF/A mode (i.e. read-only mode) to prevent modification.

    In my case however, a PDF/A compliant file is always opened in normal mode and no notification about PDF/A is displayed. In Preferences/General tab the Show PDF/A message again mode is on. Also in Preferences/Documents the PFD/A View mode is set to View documents in PDF/A mode: Only for PDF/A documents.

    I know the documents are PDF/A compliant because the Adobe Reader shows the notification about PDF/A standard and read-only mode.

    I am using latest Foxit PDF Reader version 12.0.1.0720 on MacOS (ARM version).

    Has anybody experienced the same issue?
    Last edited by Žiga Kosmatin; 08-24-2022, 12:35 PM. Reason: Typo

  • #2
    Žiga Kosmatin Can you please turn on Notification Message in Preference and check result? Attached picture for reference.
    Attached Files

    Comment


    • #3
      Dear Amanda,

      Thanks for the quick response.

      I checked the Preferences and the Notification Message is turned on.

      Click image for larger version  Name:	Screenshot 2022-08-24 at 14.24.32.png Views:	1 Size:	416.2 KB ID:	190449 Click image for larger version  Name:	Screenshot 2022-08-24 at 14.27.24.png Views:	1 Size:	414.2 KB ID:	190450
      Attached Files
      Last edited by Žiga Kosmatin; 08-24-2022, 01:46 PM.

      Comment


      • #4
        Žiga Kosmatin, As to this issue you mentioned, please help to provide us with the following information for further analysis:
        1: Did this issue happen to all files that comply with PDF/A or just particular files? Please send us one PDF file sample.
        2:Your MacOS information and device model (Is it a device with M1 or M2 chip)?
        3:Please help to uncheck the option "Enable native OS mode for optimal performance" under the "General" tab in the Preferences dialog box to see if it will help.
        4:When the PDF/A prompt message does not appear, please help to check those tools (such as Edit text ) are still clickable or grayed out.

        Look forward to your reply.
        Attached Files

        Comment


        • #5
          Dear Lisa,

          Here is some further information:

          1. The issue happens to all PDF/A Files. I am attaching a sample file which I made for this purpose.
          2. I am running macOS Monterey Version 12.5.1 on an M1 MacBook Air.
          3. I unchecked the "Enable native OS mode for optimal performace" option and ran the process as Intel via Rosetta 2. No change, the issue is still present.
          4. I am using the Foxit Reader so there is no Edit option. It is however possible to add comments to the file, which leads me to believe that the file is not opened as Read-only. (In Adobe Reader commenting is disabled in PDF/A files).

          Hope this information helps. Thanks for all the good work!
          Attached Files

          Comment


          • #6
            Thank you for the info. It has been forwarded to our QA and Dev team for further investigation, report id: MACLNX-11204
            Any update, I will post here, thank you.

            Comment


            • #7
              Žiga Kosmatin We fail to reproduce it on our side, my team advises you to locate to below file and delete them then try again to see if it helps, thank you.

              ~/Library/Preferences/com.foxit-software.Foxit PDF Reader.plist

              ~/Library/Preferences/com.foxit.PDFReaderUpdaterService.plist

              Comment


              • #8
                Unfortunately, deleting both files did not resolve the issue.

                Comment


                • #9
                  Sorry to hear that. Have you tried to remove it manually and reinstall it to see if it makes any difference? Thank you.

                  Comment


                  • #10
                    I tired manually removing and reinstalling the app but it made no difference.

                    Comment


                    • #11
                      @Žiga Kosmatin

                      We've updated your feedback to our engineer on MACLNX-11204, we'll keep you posted with further update. Thank you.​

                      Comment

                      Working...
                      X