No announcement yet.

always print with 'Actual Size' / Borland Delphi 7

  • Time
  • Show
Clear All
new posts

  • always print with 'Actual Size' / Borland Delphi 7


    is there an option to print the document always in the actual size.

    Or can you tell the program with a parameter (Borland Delphi 7) to print the real size.


  • #2
    Hi mb99,

    If you set the scale to "None" in print dialog, then it'll default to None until you make the change.


    • #3
      Hi cherry,

      thanks for your reply,

      I tried it but when I print the pdf with the shell execute or from the context menu it stil scales the content on the paper.
      Last edited by mb99; 05-27-2014, 07:43 PM.


      • #4
        Hi mb99,

        Please try to manually set None Scale and perform the printing. After this, next time when you print, please check if it is defaulted to None. Could you please kindly let me know how you print the PDF with shell execute and from the context menu? If possible, please make screenshots so we could better advise. Thank you.


        • #5
          This works when you print manualy, but when the print is ordered by the shell Foxit Reader always scales.


          • #6
            Hi mb99,

            May I know the details about how your ordered the print by the shell so we could further investigate? You may also choose to email the info to [email protected]. Thank you.


            • #7
              Hello Cherry,

              this is the command which is committed in the CreateProcess Parameter.

              'Foxit Reader.exe -t "D:\Test\ABC.pdf" "EPSON LQ-2190 ESC/P2 (Kopie 3)"'

              Thank you.


              • #8
                Hi mb99,

                Per the testing on my side, the command line printing printed the document with the scale setting "None". I went to "Start" menu of Windows, then input cmd.exe and typed in the command: "D:\Program Files\Foxit Software\Foxit Reader\Foxit Reader.exe" \t "C:\Users\Cherry\Desktop\11.pdf" "\\CHRISTINA_WU\HP LaserJet P1007"

                Could you please provide the following info?
                1) Version info of your Foxit Reader;
                2) A screenshot that compares the print results of scaled and non-scaled;
                3) Your OS info. (E.g. Win 7, 32 bits.)
                4) If my process to replicate the issue is different from yours, please specify.

                Thank you.


                • #9
                  Problem solved, the newer Version works fine sorry for the inconvience, should have try the newest version earlier.

                  Thank you very much.


                  • #10
                    It would be a great feature when there was a parameter for that issue.


                    • #11
                      Hi mb99,

                      Thanks for the update. And I've already forwarded your request for supporting scaling force via command line. Suggestion ID#: READER-933.


                      • #12
                        Sorry to bring this up but I'm trying to save a file as pdf using foxit reader PDF printer and images are not being saved with the actual size, is there a way to save them with actual size ?

                        In foxit print setup properties I cannot find the none scale option anywhere, can someone please help me ?

                        Thank you


                        • #13

                          Please help to provide us with the following info;
                          1. Which program do you print from? And its version.
                          2. The original file and its pdf file for internal test, if it is inconvenient to upload here, you may email the PDF document to [email protected].
                          3. Is there scale option in the printing dialog box? Please send us the screenshot of printing dialog box you set.
                          4. Please run Foxit, go to Help>About Foxit Reader to check the version you use.