Announcement

Collapse
No announcement yet.

Very High CPU usage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Very High CPU usage

    I am using foxit reader Version 6.2.0.0429 on windows 8.1 and Windows 7. When I open multiple documents the CPU usage jumps to 60/70 and sometime 100%. it stays there and only comes down when I close foxit reader.

    it used to be normal with previous version of foxit reader. Has anyone else experienced the same issue? What is the solution?

  • #2
    Hi Arunk,

    Could you please help provide the following info?
    1) Screenshots that shows the high CPU usage and the processes;
    2) Your Computer info:
    http://exchange.foxitsoftware.com/IS...mputerInfo.exe
    Please run it>click GetInfo>choose Save> send the saved TXT file.

    Thank you. If it is inconvenient to upload here, you may email to [email protected].

    Comment


    • #3
      May i suggest you to delete Foxit Cloud component from Foxit Reader by removing the"CloudReading"from control panel to see if it helps?Thank you.

      Comment


      • #4
        Originally posted by richell_huang View Post
        May i suggest you to delete Foxit Cloud component from Foxit Reader by removing the"CloudReading"from control panel to see if it helps?Thank you.
        This solved an issue where my CPU would spike causing my desktop temps to rise. I uninstalled the Foxit Cloud component by going to my Control Panel>>Programs and Features>> selecting Foxit Cloud>> Uninstall.

        This removed Foxit Cloud and immediately my CPU usage returned to normal and my temps lessened as well by ~20C on average. I hope Foxit is able to look into why Foxit Cloud causes that unrelenting spike in CPU usage.

        Comment


        • #5
          I'm having the same problem. I joined this forum in search of an answer. I do not have Foxit Cloud Reading services on this machine, so that can't be my solution.

          Comment


          • #6
            Hi Tonykara,

            1) Please check if you encounter this issue with any PDF document or just a specific one?
            2) Please go under "File"->"Preferences"->"Updater"->choose "Do not download or install updates automatically" and see if it helps.

            Comment


            • #7
              Just wanted to bump in to say, that uninstalling the foxit cloud and disabling automatic updates solved the same problem the OP had for me.

              Comment


              • #8
                Same issue was in my laptop with i3 4th Gen processor. It was using 25% cpu. After reading on this thread that disabling Foxit Cloud solves the issue, I did it. And now it it using only 2% CPU max.

                Comment


                • #9
                  If there is any user who encounters the high CPU usage issue,please try the following procedures step by step to see if anyone of them would help:

                  Step 1:
                  Navigate to Foxit Reader main installation folder and open"plugins"folder there,somewhere like:
                  "C:\Program Files (x86)\Foxit Software\Foxit Reader\plugins"
                  or
                  "C:\Program Files\Foxit Software\Foxit Reader\plugins"
                  please rename or delete "DocoShare.fpi"plugin.

                  Step 2:
                  Please delete or rename"FoxitCloudLogin.fpi " in plugins folder that I have mentioned in first step.

                  Step 3:
                  Please remove "Foxit Cloud"by uninstalling it from control panel.
                  If all the above methods make no difference,please help to email the issue to "[email protected]" for us to do further investigation.

                  Comment


                  • #10
                    After uninstalling FoxitCloud and removing all of the .fpi plug-in files (keeping only Updater.fpi), Foxit Reader runs like the small, fast and "Best Reader for Everyday Use!" that I expect.
                    Version 7.2.0.722

                    Comment


                    • #11
                      It's great. All the info in one place.
                      Last edited by Edelune; 09-28-2015, 02:02 AM.

                      Comment


                      • #12
                        Originally posted by Lisa_lee View Post
                        If there is any user who encounters the high CPU usage issue,please try the following procedures step by step to see if anyone of them would help:

                        Step 1:
                        Navigate to Foxit Reader main installation folder and open"plugins"folder there,somewhere like:
                        "C:\Program Files (x86)\Foxit Software\Foxit Reader\plugins"
                        or
                        "C:\Program Files\Foxit Software\Foxit Reader\plugins"
                        please rename or delete "DocoShare.fpi"plugin.

                        Step 2:
                        Please delete or rename"FoxitCloudLogin.fpi " in plugins folder that I have mentioned in first step.

                        Step 3:
                        Please remove "Foxit Cloud"by uninstalling it from control panel.
                        If all the above methods make no difference,please help to email the issue to "[email protected]" for us to do further investigation.
                        I executed this step and now the problem is solved for me.

                        Thanks Lisa_Lee

                        Comment


                        • #13
                          This solved an issue where my CPU would spike causing my desktop temps to rise. I uninstalled the Foxit Cloud component by going to my Control Panel>>Programs and Features>> selecting Foxit Cloud>> Uninstall.
                          Gaming Pc's, Custom Built Cheap Gaming Computer Systems, The lastest Gaming PC Systems, Intel i7 PC Gaming Desktops. Configure your own Gaming Pc Here!

                          Comment


                          • #14
                            Originally posted by Lisa_lee View Post
                            If there is any user who encounters the high CPU usage issue,please try the following procedures step by step to see if anyone of them would help:

                            Step 1:
                            Navigate to Foxit Reader main installation folder and open"plugins"folder there,somewhere like:
                            "C:\Program Files (x86)\Foxit Software\Foxit Reader\plugins"
                            or
                            "C:\Program Files\Foxit Software\Foxit Reader\plugins"
                            please rename or delete "DocoShare.fpi"plugin.

                            Step 2:
                            Please delete or rename"FoxitCloudLogin.fpi " in plugins folder that I have mentioned in first step.

                            Step 3:
                            Please remove "Foxit Cloud"by uninstalling it from control panel.
                            If all the above methods make no difference,please help to email the issue to "[email protected]" for us to do further investigation.


                            Hello All,we have released V7.2.2 of Foxit Reader which has already rectified the High CPU usage problem. So you may try to upgrade to V 7.2.2 without doing the above steps that I listed(such as uninstalling Foxit Cloud) to observe its CPU usage situation.If there is still any problem in V 7.2.2,please make sure to let us know.

                            Comment


                            • #15
                              Originally posted by Lisa_lee View Post



                              Hello All,we have released V7.2.2 of Foxit Reader which has already rectified the High CPU usage problem. So you may try to upgrade to V 7.2.2 without doing the above steps that I listed(such as uninstalling Foxit Cloud) to observe its CPU usage situation.If there is still any problem in V 7.2.2,please make sure to let us know.

                              Hi Lisa,

                              I recently installed Foxit Reader on my new Windows 10 laptop. However, it seems that Foxit Cloud has been integrated with the software so there is no option to uninstall the Cloud service anymore! I already have many other options to upload my PDFs (Mendeley, Dropbox, Google Drive, etc...) and I just want a version of Foxit Reader without the bloat. Will there be an updated version without Cloud available as an option in the downloads page, or should I start looking for another PDF reader before Foxit joins the ranks of the dreaded Adobe Acrobat Reader?

                              Comment

                              Working...
                              X