Announcement

Collapse
No announcement yet.

Sharepoint mapped drive issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Sharepoint mapped drive issue

    We access our documents on Sharepoint 2013 online using a mapped drive in Windows Explorer. This was fine until the recent Foxit Reader update and we could open PDFs directly from files in the mapped drive.

    This is now no longer possible and we get an error message whenever we try and open a PDF. The error is "Could not connect to the server". It asks if the URL is correct. This error only relates to the mapped drive and opening local PDFs is fine. Has anyone else experienced this?



  • #2
    Same issue here. We map drives using WebDAV just like Sharepoint (using DriveHQ) and the 7.x update causes the following error: "Could not connect to the server. Please check your network connection. Also, check if the URL is in the correct format and ensure that you have permissions to access the network resource."

    I have 50 users using Foxit this way. I only have a handful with this error. Some are on 6.?.x and others have updated to 7.x. No rhyme or reason or pattern i can see. Help?

    Comment


    • #3
      Same problem here, using WebDAV and windows 8.1, Foxit v7.0.3.916

      Comment


      • #4
        Hi guys,

        This issue has been fixed in current internal version, which means that the next release Foxit Reader 7.0.6 will no longer have this problem. Foxit Reader 7.0.6 should be available at the end of this month or early next month.

        Comment


        • #5
          Sorry to say it is not fixed. I have Windows 7 pro and Foxit PhantomPDF 7.0.6.1126 installed and can't open PDFs from mapped WebDAV. Click image for larger version

Name:	Foxit_error.png
Views:	109
Size:	20.0 KB
ID:	37918
          Attached Files

          Comment


          • #6
            Hi Greg,

            It seemed that you were trying to access the files located on WebDAV directly from inputting IP address. Could you please let us know if you try to access directly via the IP address? What about the result if you mapped the WebDAV before trying to open? Thank you.

            Comment


            • #7
              Hi Cherry, I actually am trying to access the files via a mapped WebDAV drive. It is the only way I access these files. I never tried accessing via IP until your post and I tried and can't even get authenticated to be able to access the files. Looks like the provider doesn't allow that.

              Comment


              • #8
                if I switch my default pdf viewer back to Adobe reader it works with no issue..

                Comment


                • #9
                  Hi Greg,

                  Could you please kindly let us know your SharePoint Version and also make a screenshot that shows how you try to access the files via a mapped WebDAV drive? I'll forward this info to QA team for taking a closer look at.

                  Comment


                  • #10
                    Hi Greg,

                    Our Dev team compiled a new IntegrateWithSP.fpi file for you. Please download it from this link: http://exchange.foxitsoftware.cn/Che...rateWithSP.fpi
                    Then browse to the installation folder of Foxit PhantomPDF (by default it is: "C:\Program Files\Foxit Software\Foxit PhantomPDF\plugins"), rename the old "IntegrateWithSP.fpi" (E.g. IntegrateWithSP2.fpi), place the new IntegrateWithSP.fpi in. After that, please try to replicate the problem. The new .fpi file will generate a Foxit_SPPlugin_Exe.Log at your desktop, please send it back to us for further analyzing. Thank you.

                    Comment


                    • #11
                      Hi, Cherry. I had tried to open a file on a mapped webDAV folder after changing "IntegrateWithSP.fpi" and read the logs. Then I found a problem in the logs.
                      I had mapped the folder with secure HTTP address such as "HTTPS://webdav.domain.com:9000/..." but the logs recorded the address non-secure HTTP address, "HTTP://[email protected]@9000/.... I think that is wrong address because the port number 9000 is only allowed for secure HTTP.
                      I hope the bug will be fixed soon.
                      Last edited by asbawi; 01-15-2015, 12:13 AM.

                      Comment


                      • #12
                        Hi asbawi,

                        Sorry for the delay. Is it possible to provide screenshots of the problem so I could better report the mentioned problem to QA team and Dev team for further investigation? Which version of Foxit Reader are you having now? Please email the info to [email protected], Attn: Cherry. Thank you.

                        Comment


                        • #13
                          Hi cherry.
                          I think that the following log data is sufficient for you to understand my problem.
                          I use latest version of foxit reader, 7.0.6.1126.

                          =============NORMAL LOG START=====================================
                          2015/01/15 10:19:59

                          Original file path: \\[email protected]@9006\DavWWWRoot\TeamNSE\20.DOCS\filen ame.pdf
                          Really used file path: http://[email protected]@9006/Te...S/filename.pdf


                          =============HTTP COMMAND LOG START=====================================
                          2015/01/15 10:19:59

                          URL : http://[email protected]@9006/Te...S/filename.pdf
                          Http method : OPTIONS
                          Http object name : /TeamNSE/20.DOCS/
                          Send Content :

                          Server Response :
                          Error occurs : HttpStatusCode is 0, LocalErrorCode is 0.

                          Comment


                          • #14
                            Hi asbawi,

                            Thanks for the info and Sorry for the delay. I've forwarded the info to our QA team for testing references. I got several more questions as below:
                            1) Version info of your SharePoint;
                            2) Your OS type info;
                            3) What error did you get when you try to open the PDF files that stored in WebDAV folder? Please make a screenshot of it;
                            4) Please rename the IntegrateWithSP.fpi plugin located in the installation folder of Foxit Reader and see if the rename helps.

                            Thank you again.

                            Comment

                            Working...
                            X