Announcement

Collapse
No announcement yet.

Foxit Reader not using the Windows default printer in the print dialog

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Foxit Reader not using the Windows default printer in the print dialog

    We are experiencing a problem with Foxit Reader Enterprise (Version
    7.0.6.1126) when using the print dialog: Foxit Reader does not choose
    the Windows default printer when opening the print dialog (CTRL+P), but
    some other printer.

    As you can see on the screenshots, the default printer is "HP auf
    print.m.i2n" (\\print.m.i2n\HP). But Foxit Reader
    chooses "\\print.m.i2n\HP_Briefpapier" after pressing CTRL+P.

    Click image for larger version

Name:	default_printer.jpg
Views:	954
Size:	49.2 KB
ID:	39502

    Click image for larger version

Name:	default_printer_wrong.jpg
Views:	977
Size:	44.2 KB
ID:	39503


    Foxit Reader seems to have a problem with not recognizing the right
    default printer when the default printer is a shared network printer (CIFS)
    and there are multiple printers on the same server.

    When there is only the one default printer on the network server, Foxit
    has no problems selecting it in the print dialog. See the attached screenshots.

    Click image for larger version

Name:	change_default_printer.jpg
Views:	947
Size:	96.4 KB
ID:	39495

    Click image for larger version

Name:	default_printer_right.jpg
Views:	959
Size:	46.9 KB
ID:	39504
    Here are the relevant parts of the Registry as exported by regedit:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows]
    "UserSelectedDefault"=dword:00000001
    "Device"="\\\\print.m.i2n\\HP,winspool,Ne02:"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Devices]
    "Microsoft XPS Document Writer"="winspool,Ne00:"
    "Fax"="winspool,Ne01:"
    "PrimoPDF"="winspool,Ne00:"
    "\\\\print.m.i2n\\HP"="winspool,Ne02:"
    "\\\\print.m.i2n\\HP_Briefpapier"="winspool,Ne 03:"
    "\\\\print.m.i2n\\HP2"="winspool,Ne04:"
    "\\\\print.m.i2n\\HP2_Briefpapier"="winspool,N e05: "
    "\\\\print\\HP"="winspool,Ne06:"
    Last edited by Neurasthenie; 12-12-2014, 01:04 PM.

  • #2
    This issue has been addressed and will be fixed in next release 7.1.

    Comment


    • #3
      Originally posted by richell_huang View Post
      This issue has been addressed and will be fixed in next release 7.1.
      Any estimate when version 7.1 wil be released?

      Comment


      • #4
        Foxit Reader 7.1 will be released in this month if everything goes well, please keep an eye on the new release.

        Comment


        • #5
          Hello. I am having this same problem with Foxit Reader, I have version 7.1.5.425. Instead of using the default printer for my computer, it goes to Foxit Reader PDF printer. Isn't there any way to set the default printer for Foxit? Thanks!

          Comment


          • #6
            Hi constans,

            Please re-install both Foxit Reader and your printer drive and see if it helps. If not, please let us know the following info:
            1) Are you running in a server environment? Environment info?
            2) Printer info; Open "Control Panel\Hardware and Sound\Devices and Printers", then choose the printer, open Properties->General, check the Model info.
            3) How did the default printer been set? Via registry editor or 'Control Panel'->'Printers and Fax' ?
            4) How the Printer was connected?

            Comment


            • #7
              Hello -

              I'm having a similar issue.. it's not a problem with the default printer being selected but NONE of my network printers show up in Fox it at times. It appears to be some type of user registry setting as creating a new profile fixes it.. until it breaks again. It also is intermittent where it might work for a user for one Foxit Session and then not again another time.

              I have Foxit Reader 7.2.8.1124 running on two Windows Server 2012 R2 servers. The printers show up when you go to control panel, just aren't mapped within Foxit. What gives?

              Thanks for any help.

              Comment


              • #8
                Hi Mjlevine,

                Sorry for the trouble. I have reported the issue to our team, they will do further investigation,report ID:68197
                You may email to [email protected] with this ID# to track the processing status.
                Thank you.

                Comment


                • #9
                  I'm moving to a new(er) Win 7 Pro machine and Foxit worked a couple of days ago but my Canon MF3240 was only printing. I think because I was installing the OLD drivers. In the last couple of days I have managed to get the MF3240 scanning and got my OCR software running again....

                  NOW I am having the same problem as these folks - Foxit just doesn't see my printer!!

                  I downloaded today - also tried the "Portable" version.

                  Comment


                  • #10
                    Is it looking in the wrong place for the printer driver?? I use Revo to uninstall, so the old driver wouldn't be there if I re-installed it!

                    Comment


                    • #11
                      KenF

                      We're beta testing Foxit Reader/PhantomPDF 8.0 for now. Version 8.0 should have fixed the mentioned problem. Could you please give it a try at your convenience? You may sign up for the beta version trial from this link: https://www.foxitsoftware.com/previe...ompdf-beta.php

                      Comment


                      • #12
                        Cherry,

                        Happy to try that. As I'm downloading I notice that FireFox also can't print under the menu "File">Print or even Print Preview!! Don't know when that started but I'll investigate that - seems like mine may be a wider problem!

                        Here's a screen shot of the error in foxit...

                        OBTW That IS Phantom Beta
                        Last edited by KenF; 06-08-2016, 09:14 PM.

                        Comment


                        • #13
                          OH, THIS I SOOooo STUPID!!!

                          Another MicroSofty for you - WHY can't they just tell us that the Print Spooler isn't running????

                          So many people have had this problem and the best advice starts of with "stop the Print Spooler". (I'll include it here for anyone who might need it....)

                          OF COURSE, if you can't FIND the Print Spooler Service that may be a clue!!

                          A SIMPLE RE-BOOT WILL PROBABLY FIX IT!!!

                          Ouch!!


                          Thanks for all your help, hope this helps others and keeps them off you back.

                          (LOVE MS.... NOT!)


                          =======================

                          From https://social.technet.microsoft.com/Forums.....This steps do work well for me.

                          Do them at your own risk.
                          Backup registry before you do anything!!!!
                          Stop "Print Spooler" service first

                          Then base on your platform delete all keys below the version-3
                          for 32 bit
                          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Print\Environments\Windows NT x86\Drivers\Version-3

                          for 64 bit
                          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Print\Environments\Windows x64\Drivers\Version-3


                          go to the folder "3"
                          C:\Windows\System32\spool\drivers\w32x86\3
                          rename it to "3.old"

                          Start the "Print Spooler" again and install your printers

                          =======================================

                          Comment


                          • #14
                            Originally posted by KenF View Post
                            OH, THIS I SOOooo STUPID!!!

                            Another MicroSofty for you - WHY can't they just tell us that the Print Spooler isn't running????

                            So many people have had this problem and the best advice starts of with "stop the Print Spooler". (I'll include it here for anyone who might need it....)

                            OF COURSE, if you can't FIND the Print Spooler Service that may be a clue!!

                            A SIMPLE RE-BOOT WILL PROBABLY FIX IT!!!

                            Ouch!!


                            Thanks for all your help, hope this helps others and keeps them off you back.

                            (LOVE MS.... NOT!)


                            =======================

                            From https://social.technet.microsoft.com/Forums.....This steps do work well for me.

                            Do them at your own risk.
                            Backup registry before you do anything!!!!
                            Stop "Print Spooler" service first

                            Then base on your platform delete all keys below the version-3
                            for 32 bit
                            HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Print\Environments\Windows NT x86\Drivers\Version-3

                            for 64 bit
                            HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Print\Environments\Windows x64\Drivers\Version-3


                            go to the folder "3"
                            C:\Windows\System32\spool\drivers\w32x86\3
                            rename it to "3.old"

                            Start the "Print Spooler" again and install your printers

                            =======================================
                            Dear KenF,Thanks so much for sharing the workaround with us.

                            Comment

                            Working...
                            X