Announcement

Collapse
No announcement yet.

Multiple pages per sheet 1x2 printing in wrong order

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Multiple pages per sheet 1x2 printing in wrong order

    This is bugging me since a while and I'm not sure whether it's a bug or me not using Foxit Reader correctly.

    I'm trying to print two pages on one page. When I use the printer properties dialog (Properties > Layout > Pages per Sheet : 2) everything is fine.

    The problem is Foxit's own print dialog:


    As you can see I chose the following options (i marked the page numbers in the preview for clarity):
    • Multiple pages per sheet
    • Pages per sheet: 2 (1x2)
    • Page Order: Horizontal (I also tried all the others)
    • Auto-Rotate: true


    The problem is that page 1&2 should be reversed. I want the first page to appear on the left side of the paper, the second page on the right side of the paper. This happens for all PDFs so it's not a problem of this PDF but rather me being not able to choose the right settings or Foxit Reader not working the way it should

  • #2
    Please print it in this way:
    1.open any pdf file you want to print
    2.choose print button, and select multiple pages per sheet, custom 2 by 1
    3.check Auto-Rotate.
    4.Click properties->layout->change page layout from Portrait to Landscape.

    Comment


    • #3
      Originally posted by richell_huang View Post
      Please print it in this way:
      1.open any pdf file you want to print
      2.choose print button, and select multiple pages per sheet, custom 2 by 1
      3.check Auto-Rotate.
      4.Click properties->layout->change page layout from Portrait to Landscape.
      Nice! That works. But I don't think this is better than going to properties > Layout > Pages per Sheet: 2, or is it?

      Comment


      • #4
        has anyone in foxit software noticed this bug?

        this is such a really serious bug, a pdf solution should be able to handle print correctly.
        all foxit needs to do is to make the pages rotate CLOCKWISE, instead of counterclockwise, when printing 2 pages per sheet.
        or at least give users an option to choose between CW and CCW when printing... is it THAT difficult?

        well, i admit richell's workaround works, but anyway are we REALLY supposed to change printer properties whenever i want to print pdf files?

        i've been updating my foxit reader FOUR times awaiting this fix, but it is NEVER fixed.
        no problems like this occur in adobe reader... should users switch back to adobe reader JUST BECAUSE OF PRINTING problem?

        foxit should pay a little more attention to details. really.

        Comment


        • #5
          Thanks so much for your valuable comment, and we support already reported it to related team, hope it will be improved in future update.Anyway, i will send a reminder and update your feedback for their reference, i also hope it could be corrected soon.

          Comment


          • #6
            well thanks for posting such an important information , hope many people will get some help from this valuable information , well this is really a big bug and it needs to be done correctly, this foxit makes the pages to rotate clockwise instead of counter clockwise, i must say thanks again for this valuable information and best of luck for your future.

            Comment


            • #7
              Hmm. This might be related to a bug I'm encountering:

              When printing a multi-page pdf either two-up or booklet (if the printer driver has a 'booklet' option, e.g. Samsung CLP) only the odd pages (#1,3,5 ..) are printed. I haven't investigated many possible work rounds, but precisely the same sequence of printer set ups works fine in Adobe Reader.

              Can waste a lot of paper like this!

              (First post here so apologies if this is known (or better still) fixed bug.)

              Comment


              • #8
                Any takers for my odd page problem (above)?

                (Or have you all been silenced by the "wit" of Ramirezen?!)

                Comment


                • #9
                  Originally posted by Marghek View Post
                  Hmm. This might be related to a bug I'm encountering:

                  When printing a multi-page pdf either two-up or booklet (if the printer driver has a 'booklet' option, e.g. Samsung CLP) only the odd pages (#1,3,5 ..) are printed. I haven't investigated many possible work rounds, but precisely the same sequence of printer set ups works fine in Adobe Reader.

                  Can waste a lot of paper like this!

                  (First post here so apologies if this is known (or better still) fixed bug.)

                  Sorry for the delay.May i know which version of Foxit Reader do you use?Would you mind describing your operation steps and work environment detailed so we could simulate your situation to reproduce it?Thank you.

                  Comment


                  • #10
                    Hi and thanks for replying.

                    I am using Reader version 4.3.1.0323. I realise this isn't the latest, but the updater won't allow me to select any of the three 'available updates' because the 'Add' button is greyed out. (If the bug is fixed in a later version, please tell me how to install the updates).

                    Windows XP 3. A multi-page pdf of 15 pages - created by CutePDF, if that's relevant - displays fine. But when printed as a booklet to Samsung CLP original pages 2, 4, 6, 8, 10, 12 and 14 are not printed, so the booklet prints as two double-sided A4 sheets instead of four. Similar problem when printing 'two up': here it is easier to see that original P1 is followed on the right by P3, next P5 is followed by P7 and so on - even pages omitted. It looks to me as though the even pages are not being sent from Foxit Reader.

                    Change to Adobe Reader, display the same 15 page pdf and print from there using the same printer and driver: all pages are printed.

                    No great prob, as I can run up Adobe when I need to print in booklet form, but I thought you'd like to know.

                    Comment


                    • #11
                      Hi Marghek,
                      Thank you for the feedback, this issue should be fixed in the latest 5.3.1.There is something wrong with the updater in version 4.3, would you mind uninstalling it manually and download the latest 5.3.1 from below link:
                      http://cdn04.foxitsoftware.com/pub/f..._enu_Setup.exe

                      Comment


                      • #12
                        Hi,

                        5.3.1 fixes the booklet printing - thanks.

                        There are still "issues" with 2 up printing though. I can get 2 up printing - by specifying 4 up!! And the pages are then in the wrong order: 2 on the left, 1 on the right etc. as far as I can tell. Specifying 2 up is just ignored.

                        Not to worry, though. 5.3.1 is pretty and works for what I need to do. Thanks again.

                        Comment


                        • #13
                          Regarding printing wrong order, please try below instructions.
                          1.open any pdf file you want to print
                          2.choose print button, and select multiple pages per sheet, custom 2 by 1
                          3.check Auto-Rotate.
                          4.Click properties->layout->change page layout from Portrait to Landscape.

                          BTW, what do you mean "Specifying 2 up is just ignored", would you please describe it detailed?

                          Comment


                          • #14
                            Ah!

                            When I obey your instructions 2 by 1 works correctly. Many thanks.
                            I was setting "2 up" and "4 up" in the printer driver via the properties button. Seems some printer drivers ignore these settings.

                            There isn't a 'booklet' printing option in Foxit Reader (is there?) so one has to rely on the printer driver (properties) (a) having a booklet option and (b) it working !

                            Sorted. Thanks again.

                            Comment


                            • #15
                              Hi laureta,

                              Tks. That was richel_huang's instruction on 14 August and it works for 2 by 1 printing.

                              But there's no 'booklet' printing option in Foxit Reader so one has to choose that option in printer properties (if it's available there, and if it works - which was my original problem, solved by the latest version of Foxit Reader ).

                              Comment

                              Working...
                              X