Announcement

Collapse
No announcement yet.

XP support?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • wilk
    replied
    That's a great news. I will contact there, thank you.

    Leave a comment:


  • lyndi_wu
    replied
    Hi Wilk,

    Sorry for the inconvenience. If you want the previous version, may I suggest you to email your requirement to [email protected]?
    We will reply you the download link for the version you want. Thank you for your understanding.

    Leave a comment:


  • wilk
    replied
    Originally posted by lyndi_wu View Post
    As you may know, windows Xp is old system that MS do not maintain the version any more, so we will not fix the bugs which just happens on WinXp, thank you for your understanding. Maybe you can try to uninstall Foxit Cloud from Control panel to see if it helps on your side.
    I know and I'm aware of this (well, maybe skipping the fact that POSReady is supported till 2019, but seems no one in the world cares about this). However XP has still large user base. Anyway I always uninstall Foxit Cloud after installation as I don't use it (I just want safe and simple PDF viewer). The issue is, as I described in the first post, related to SSE2 which was enabled during compilation. The app executes an instruction which CPU does not have. Actually the problem is twice as deep, because Foxit could probably run on WinXP, however not on AthlonXP (don't be confused by "XP"), but this Athlon is supported by XP. So the only solution is to stick with old release forever or look for a working PDF viewer. Sadly Foxit company does not provide official package for previous releases any longer, why? That's humorous because you still provide a package for for example CE 4.2 which support ended in... july 2013. Now I have to look on 3-party sites for a previous version, risking possible malware/unwanted software attached, just because 7.1 installator has not verified if it can even run and crippled my older, working version...

    To summarize: You should remove incorrect information that version 7.1.0 supports WinXP (7.1.3 is Vista+) because it is not true - it does not support CPUs that XP normally supports.

    Leave a comment:


  • zhoudani
    replied
    If I have the solution,I will tell you immediately!
    ___________________
    Recommend a site about rs gold at rsgoldfast

    Leave a comment:


  • lyndi_wu
    replied
    Dear Wilk,

    As you may know, windows Xp is old system that MS do not maintain the version any more, so we will not fix the bugs which just happens on WinXp, thank you for your understanding. Maybe you can try to uninstall Foxit Cloud from Control panel to see if it helps on your side.




    Leave a comment:


  • wilk
    replied
    Windows XP - maybe. Unfortunately 7.1.x binaries are compiled with enabled SSE2 optimizations and there is no warning given neither on main site nor during installation (upgrade), so executable crashes just on execution, hence this pdf reader, sadly, is no longer usable... (CPU is Athlon XP - so SSE only)

    If devs are interested, by any chance:

    Code:
    CRASHLOG caused an Illegal Instruction (0xc000001d)
    in module FoxitReader.exe at 001b:01bbff4e.
    
    Error occurred at 4/12/2015 16:30:32.
    C:\Program Files\Foxit Software\Foxit Reader\FoxitReader.exe, run by wilk.
    Reader Version : 7.1.3.0320.
    Operating system:  Windows XP (5.1.2600).
    1 processor(s), type 586.

    Leave a comment:


  • richell_huang
    replied
    Sorry to hear that. Currently release 7.1 still works for XP, you may want to have a try, thank you.

    Leave a comment:


  • etniak
    replied
    That's disappointing. I'm running a "hacked" XP (POSReady) that is still getting security updates, possibly for a few more years. I switched to your product after Adobe abandoned XP.

    Leave a comment:


  • richell_huang
    replied
    Current version may not work stable for XP, and we have reported it to QA team for further analysis.
    Last edited by richell_huang; 06-05-2015, 12:13 PM.

    Leave a comment:


  • etniak
    started a topic FAQ XP support?

    XP support?

    Can anyone confirm if the latest version of Foxit Reader still supports XP? It is not listed in the system requirements (only Vista, Win7, 8) so I'm trying to confirm whether to upgrade from 7.0 to 7.1. Thanks.
Working...
X