Announcement

Collapse
No announcement yet.

Latest Version of Foxit Reader ~ Can't Click on URL/Links in PDF ~ Safe Mode UNCHECKE

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug Latest Version of Foxit Reader ~ Can't Click on URL/Links in PDF ~ Safe Mode UNCHECKE

    Just downloaded the latest version of Foxit Reader (Version 5.3.1.0606)

    I've also UNCHECKED "Enable Safe Reader Mode" under Tools/Preferences and yet Foxit Reader still WILL NOT link to any URL embedded in the PDF's that I'm trying to read...

    What's going on w/this and how can I fix it?


    Thanks!
    Attached Files

  • #2
    Would you mind attaching one file sample to us for a closer look?Or you can send it to [email protected], thank you.

    Comment


    • #3
      Per your request....

      Here's a simple PDF file with one line of text and a hyper-link that Foxit Reader will not link to:

      PDF_Example.pdf

      Look forward to resolving this issue asap!

      Comment


      • #4
        Any updates/resolutions as of yet by chance...or problems w/the example PDF file that was submitted?

        Comment


        • #5
          Sorry for the delay.Actually, it is not an active link but one sentence with underline, which looks like a link.So you fail to access it.

          Comment


          • #6
            yes..it's a link...document was created in MS Word...and a hyper-link added....hyper-link works in MS Word (2003)...but once converted to PDF...link is no longer 'active'...

            In the past, while using Foxit Reader, I've had no issues of being able to have Foxit Reader open up a web browser and link to a particular web page from within any PDF document.

            However, since the last time I updated Foxit Reader, hyper-links don't work!

            Comment


            • #7
              May i know how do you print the Word file to PDF file?I believe the link in Word is an active link, but it lost when printing to PDF format file. So you can not access it with Foxit Reader, either Adobe Reader.
              If you use Foxit Printer to convert it, you should click the Add-in icon to print it so the link can be preserved.

              Comment


              • #8
                Sorry for the delay in responding, been on vacation w/the family for the last few days..

                In regards to your question, I use an app called CutePDF...it's always worked with either Adobe Reader and/or Foxit Reader...

                Side Note: After further testing, Foxit Reader WILL ONLY link out to any web address ONLY IF the URL within the PDF document itself actually shows

                http://www.domain-name-here.com

                vs

                www.domain-name-here.com

                Not sure why...

                Comment


                • #9
                  I had a similar problem with not being able to click/select links, they only appeared as blue underlined text and were not clickable. The solution for me was to use/select the hand tool before clicking the links. I constantly use the text selection tool but found that when using this tool the links are not clickable, I had to use the little hand tool.. and that works. I hope that this helps out someone else who may have the same problem. -Tracy

                  Clarification Update:
                  To be able to click links that connect to websites you will also have to go to EDIT/PREFERENCES/TRUST MANAGER and un-check the "Enable Safe Reading Mode" box. But.. to click links that take you somewhere within the same PDF (doesn't connect to a website) you only have to use the little hand tool.. you don't have to un-check the "Enable Safe Reading Mode" button.
                  Last edited by cybersoil; 10-01-2012, 08:16 PM. Reason: Clarification

                  Comment


                  • #10
                    Dear AFoxitUser,
                    Thanks for the update. You said that you used CutePDF to convert the word document into PDF file. I am definitely sure that the hyperlink in original word document hasn't been preserved in the converted PDF document during the conversion.So there is not any URL embedded in the blue text object that you want to click. You can try to open the file with other PDF viewer,such as adobe reader,PDF-Xchanger et,we will find that you are unable to access it in any PDF viewer.
                    In additon,it must be mentioned that our foxit reader is able to visit
                    any type of hyerlink including the link which has embedded URL. Attached is a PDF file with embedded URL for your reference.
                    Attached Files

                    Comment


                    • #11
                      Having this issue again...

                      Foxit Reader is yet again not opening links to outside websites..

                      I've gone through Firefox, Chrome and even MS Internet Explorer and set each one to be the 'default browser'...

                      Heck, I have even one step further and performed the following steps to 'force' a default browser being selected:

                      http://support.mozilla.org/en-US/kb/...k#w_windows-xp

                      and yet, I still can't any of my PDF's, which all contain links to 3rd party websites to open in any browser.

                      The most recent PDF that isn't working is found here:
                      http://www.faststreamofmoney.com/mys...ts_updated.pdf

                      O/S: Windows XP SP3

                      Any help in resolving this issue would be greatly appreciated!

                      Comment


                      • #12
                        I have experienced 2 versions of this same problem, both on PCs running Windows 7 and Foxit 5.4.5.0124. In one case, when I mouse over the link there is no link (as though it is an underlined string of characters). In the other PC, you can click the link, but it includes part of the sentence after the link (i.e. the intended URL, followed by a few words and separated by exclamation points) and of course get an error. I downloaded Adobe Reader on the 2nd PC, opened the same PDF using Adobe, and the links work perfectly so it is clearly a Foxit issue. Any suggestions (other than using Adobe)?

                        Comment


                        • #13
                          selecting hand tool worked for me

                          [QUOTE=cybersoil;27800]I had a similar problem with not being able to click/select links, they only appeared as blue underlined text and were not clickable. The solution for me was to use/select the hand tool before clicking the links. I constantly use the text selection tool but found that when using this tool the links are not clickable, I had to use the little hand tool.. and that works. I hope that this helps out someone else who may have the same problem. -Tracy

                          Thanks Tracy. This solved my perplexing problem.

                          I created PDF from word 2010. The TOC was active in word, but I could not find clickable links using foxit reader. The links were clickable in Adobe reader.

                          When I changed to "hand tool" Hey Presto the links became clickable.

                          I tried other suggestions offered, including "un-checking" follow links, no of which worked.

                          Comment


                          • #14
                            You have to love it when a regular user knows things about a program that a company representative doesn't.

                            Anyway that's all out the window now that Foxit has joined the club of "let's all adopt the stupid new Microsoft UI" programs. Now the hand automatically turns into the text cursor when you hover over a link. Way to go Foxit for messing up something as critical as being able to click on links. Thanks for nothing.

                            There was a time when "Better than Adobe PDF Reader and Acrobat - Foxit" was something more than just a slogan. I will now be switching to a PDF reader that actually works, in which I can click on a link and actually get a broswer window that displays the page linked to, for example Adobe PDF Reader.

                            Comment


                            • #15
                              Hi Glass Deviant,

                              We can go to 'File' menu->'Change Toolbar Mode'->change the user interface to Classic Toolbar Mode. To stop the hand tool from automatically turning into the text cursor, you can go to 'File'->'Preferences'->'General'->uncheck "Make Hand Tool select text".

                              Comment

                              Working...
                              X