No announcement yet.

FORCE Foxit Reader to ALLWAYS use continuous mode!!!!

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Maybe continuous scrolling should be part of "fit width" so it's just one click. That would even be a lot better and more intuitive than what's going on right now. "Autoscroll" isn't a very good description for "enable and disable this to quit jumping to the next page while I'm trying to read the end of a page".


    • #17
      2+ years later and this simple but essential option hasn't been added or at least I can’t figure out how to do it in version I have the defaults set to 'Single Page' and 'Fit Page' but they are just ignored. I don’t see an 'Initial view' field under 'File'->'Properties' on the pdf's I checked. I opened a pdf in notepad+++ and it shows the data below. If I delete '/PageLayout /TwoPageRight' or change it to '/SinglePage' the pdf will open in SinglePage.

      /ViewerPreferences <<
      /HideWindowUI true
      /Metadata 3568 0 R
      /Pages 2 0 R
      /PageLayout /TwoPageRight
      /Type /Catalog

      Under 'Default page layout' there is an 'Automatic' setting if this is selected the pdf should be opened using the page layout set in the pdf but if any of the other option is selected the page layout should be overridden. I can't think of one reason why you need to honor the pdf's page layout over a setting set by your users. If I want every pdf to open in SinglePage with the zoom Fit Page why shouldn’t I be able to? Just to be clear this isn’t an issue of view settings being saved it’s about opening a pdf for the first time or with 'Restore Last view settings' unchecked.

      In another post a mod said the priorities are.
      1. Initial View set in pdf
      2. "Restore last view settings when reopening" option
      3. "Default Page Layout" option under "Preferences"

      No clue where this logic came from and it should be like this. If you want to use the initial view in the pdf select automatic and uncheck restore last view or don’t change the view after you open the pdf. I don’t see how any other way makes any sense.
      1. "Restore last view settings when reopening" option
      2. "Default Page Layout" option under "Preferences"
      3. Initial View set in pdf


      • #18
        If you set the "set view mode as continuous" keyboard shortcut to something like Ctrl+E in the settings (View -> UI Options -> Customise Toolbars -> Keyboard -> View -> Page Display: Continuous) then it becomes pretty quick to change when it bothers you. It's not automatic, but it means you can change pretty much instantly.


        • #19
          Hi tbbhoiorg,

          You may right-click on the blank area of the toolbar, then click "Customize Quick Access Toolbar" then switch to "Keyboard"->choose "View" in Categories list->choose "Continuous" in Command list, then assign a shortcut for the continuous mode that you'd like. Thank you.


          • #20
            I have the same problem that jonjonjon talks about. I've tried numerous times to make Foxit use "single page" "fit page" as the initial view in Preferences, or in Properties, or both, and NOTHING works ... every PDF still opens in what looks like "fit width" view, which means I have to click Cntrl-1 every time to make it "fit page" so that I can read the document.

            (I haven't tried jonjonjon's suggestion about editing in notepad ... but that seems a little advanced for most users.)

            Why put "single page" "fit page" in preferences initial view if it DOESN'T WORK?

            Sheesh. Very irritating.


            • #21
              Dear Sheesh,

              To make Foxit Reader/Foxit PhantomPDF to open PDF file with "Fit page"as default zoom level,you have to do as follows:
              1:Go to "File">"Preferences">"Page display">choose"Fit page"for zoom item there.
              2:Click on"History"tab in preferences dialog box>uncheck option"Restore laste view settings when reopening">click"OK"to save the settings.

              Then PDF files will be opened with "fit page"zoom level by default unless some specific PDF files which includes initial settings.
              Currently foxit reader/Foxit PhantomPDF will always read those preset page initial view settings in PDF file preferentially to display the file when open it is opened in foxit reader/Foxit PhantomPDF.
              Last edited by Lisa_lee; 08-06-2016, 12:48 PM.


              • #22
                Originally posted by richell_huang View Post
                Dear pdfuser,

                Thanks for the upate.It must be mentioned that currently our foxit reader would always read those page initial view settings preferentially to display the file in foxit reader.
                So if a PDF file has been setted by file author to show"singe page" for page layout in initial view,foxit reader will show a single page at a time for the PDF file when open it regardless what setting you choose for the page display mode in foxit reader application.
                However,I have submitted the request"Add option in foxit reader to force page layout/zoom level as user want, ignore documents' initial view settings "to our foxit reader PM team for their reference. Reported ID:READER-1114. Hope it will be implemented in future version.
                5 years have passed since this request and Foxit Reader or Foxit PhantomPDF still doesn't have the option to force the desired page display settings. An option to override initial view settings set in a PDF file by the author would be so nice.

                Adobe Reader, Adobe Acrobat, Sumatra PDF, PDF-XChange - all this software has an initial view settings override feature.

                Please add this option too, Foxit.


                • #23
                  Wow... seems like that "force continuous" feature is just never going to be implemented. That's just too bad, I've really liked it since I was introduced to it but it's a terrible bother using it with academic papers =/.


                  • #24
                    Nope, this still does not work properly: even following

                    1)Tools->Preferences->History->uncheck "restore last view settings when reopening".
                    2)View->Page display->check "continuous".

                    the PDF opens in single page view mode.
                    As jonjonjon wrote, this may have to do with the PDF encoding, Foxit prefers it over its own setting. How sad, five years and still unsolved.
                    Continuous view does work well in chrome.


                    • #25
                      Dear all, For this situation you mentioned,I have forwarded the suggestion"provide preferences to override page display settings in the pdf file" as a new feature to our PM team for processing.
                      Suggestion ID#PHANTOM-4509.


                      • #26
                        How is it possible that such a basic feature in Foxit PDF Reader is missing? I have been waiting for it since the first versions of the Reader. Please, implement this ASAP as it makes your company completely arrogant to users!


                        • #27
                          Dear fbrminsk,we will add the "Override page display"setting in preferences dialog box in our next major upgrade version 9.0 of Foxit Reader,please keep an eye out for the new release.


                          • #28
                            I have tried to all the examples that have been tried each time nothing keeps it in default mode and the documents open in full view each time. Very cumbersome!


                            • #29
                              Using latest Foxit Reader v9.0.0.29935

                              Foxit Reader Preferences are set as follows:

                              File - Preferences - Accessibility

                              File - Preferences - History

                              File - Preferences - Page Display

                              I have created a test .pdf file (linked below) that has these initial view metadata settings:

                              1. Single page

                              2. Fit Width

                              3. Open to page 3

                              4. Show attachments panel and page

                              According to Foxit Reader preferences, Foxit Reader should override these Single page initial view metadata settings and open the pdf in Facing page layout style (which it does).

                              However, Foxit Reader fails to override Zoom setting to Fit page (as set in override preferences) and continues to use Fit width (as set in pdf file initial view metadata).

                              Also Foxit Reader still lacks setting to override start opening page order.

                              User should have an option in File - Preferences - Accessibility to enforce opening of pdf file from the beginning (and not from page 3 as in my test pdf example).

                              I've linked a test pdf file named Initial View (single page, fit width, open to page 3 with attachments panel).pdf

                              Please test the linked .pdf file with Foxit Reader preferences set as in images above and you'll see that Foxit Reader fails to override Zoom settings.

                              Test .pdf file can be downloaded from

                              Will Foxit fix these 2 issues (enforcement of zoom settings and opening pdf from page 1)?

                              Thank you.


                              • #30

                                Odd Ramos
                                I apologize for any hassle and inconvenience this may cause for you.Regarding the suggestion"User should have an option in File - Preferences - Accessibility to enforce opening of pdf file from the beginning (and not from page 3 as in my test pdf example).",I have submitted it as a new feature to our internal feature system for our product marketing's references with suggestion ID#QCPHANTOM-6566.

                                Concerning the issue"Foxit Reader fails to override Zoom setting to Fit page,but continues to use Fit width as set in initial view",it has been submitted to our internal
                                bug tracking system for our QA team to do further analysis with report ID#QCPHANTOM-6567.I will keep you informed for any updates about it or you may also write back to
                                [email protected] to track its processing status.