Announcement

Collapse
No announcement yet.

Foxit Reader Plugin 2.2.1.530 blocked by Mozilla

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feedback Foxit Reader Plugin 2.2.1.530 blocked by Mozilla

    Is there any work around for this? I would really like to be able to open pdf files in Firefox.

  • #2
    Never mind. I think I found the work around (until Foxit patches the Plugin).
    http://nakedsecurity.sophos.com/2013...n-for-firefox/

    Comment


    • #3
      Sorry for this inconvenience, we are contacting Firefox to update the plugin so users could update it directly.For now, you can download the latest firefox plugin from our website and install it.

      Comment


      • #4
        Originally posted by richell_huang View Post
        ...download the latest firefox plugin from our website...
        Can you post a link to that download because i cannot find it on your website.

        Comment


        • #5
          Originally posted by jrice135 View Post
          Can you post a link to that download because i cannot find it on your website.
          Here it is:

          http://cdn04.foxitsoftware.com/pub/f...2.2.3.111.fzip

          Comment


          • #6
            Originally posted by richell_huang View Post
            Sorry for this inconvenience, we are contacting Firefox to update the plugin so users could update it directly.For now, you can download the latest firefox plugin from our website and install it.
            Is this plugin compatible to reader vers. 4.3.1.0218 too?

            Comment


            • #7
              Hi holbi,

              Foxit Reader for Firefox plugin 2.2.3.1111 is not compatible with Reader 4.3.1.0218 but with Foxit Reader 5.4.5. You can find the download for v4.3 from this link: http://www.foxitsoftware.com/Secure_...der/addons.php

              Comment


              • #8
                updated Firefox plugin for Foxit Reader 4.3

                I just downloaded the updated Firefox plugin for Foxit Reader 4.3.
                The file is named firefox_plugins_2010.11.02
                which seems to indicate that the file I updated was last updared in 2010.
                Can you indeed confirm that I updated the latest plugin that deals with the 2013 security flaw.
                Thanks



                Originally posted by cherry View Post
                Hi holbi,

                Foxit Reader for Firefox plugin 2.2.3.1111 is not compatible with Reader 4.3.1.0218 but with Foxit Reader 5.4.5. You can find the download for v4.3 from this link: http://www.foxitsoftware.com/Secure_...der/addons.php

                Comment


                • #9
                  Hi techman,

                  I'm afraid that we don't have an update Firefox plugin that deals with the 2013 security flaw available for Foxit Reader 4.3. Could you please uninstall your version 4.3 then drectly download a new installer for Foxit Reader 5.4.5. The installation of Foxit Reader 5.4.5 includes the installation of the latest Foxit Readerfor Firefox plugin.

                  Comment

                  Working...
                  X